I purged the -116 packages and then re-installed them but it didn't
help.  What's worse, is that now Unity doesn't work in -112, but
fortunately my Gnome session still works fine.

Here are the commands I executed to reinstall the -116 kernel:
sudo apt-get purge linux-image-4.4.0-116-generic
sudo apt-get purge linux-headers-4.4.0-116-generic
sudo apt-get purge linux-headers-4.4.0-116
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-generic-lts-xenial

My gcc version is 6.3.0-18ubuntu2~16.04

Can someone help?

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1750937

Title:
  4.4.0-116 Kernel update on 2/21 breaks Nvidia drivers (on 14.04 and
  16.04)

Status in linux package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-384 package in Ubuntu:
  Confirmed
Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  Running fine with nvidia-384 until this kernel update came along.
  When booted into the new kernel, got super low resolution and nvidia-
  settings was missing most of its functionality - could not change
  resolution.

  Rebooted into 4.4.0-112 kernel and all was well.

  The root cause of the problem has been found to be installing the -116
  kernel without a sufficiently updated version of gcc.  In my case, my
  system received the gcc update AFTER the kernel update.

  Uninstalling the -116 kernel and reinstalling it with the updated
  version of gcc solved the problem for me.

  
  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: xorg 1:7.7+1ubuntu8.1
  ProcVersionSignature: Ubuntu 4.4.0-112.135~14.04.1-generic 4.4.98
  Uname: Linux 4.4.0-112-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  384.111  Tue Dec 19 23:51:45 
PST 2017
   GCC version:  gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3)
  ApportVersion: 2.14.1-0ubuntu3.27
  Architecture: amd64
  CurrentDesktop: LXDE
  Date: Wed Feb 21 19:23:39 2018
  DistUpgraded: Fresh install
  DistroCodename: trusty
  DistroVariant: ubuntu
  DkmsStatus:
   bbswitch, 0.7, 4.4.0-112-generic, x86_64: installed
   bbswitch, 0.7, 4.4.0-116-generic, x86_64: installed
   nvidia-384, 384.111, 4.4.0-112-generic, x86_64: installed
   nvidia-384, 384.111, 4.4.0-116-generic, x86_64: installed
  GraphicsCard:
   NVIDIA Corporation Device [10de:1c82] (rev a1) (prog-if 00 [VGA controller])
     Subsystem: eVga.com. Corp. Device [3842:6253]
  InstallationDate: Installed on 2015-03-03 (1086 days ago)
  InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
  MachineType: ASUSTeK COMPUTER INC. M11AD
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-112-generic 
root=UUID=5a88d2a1-0a24-415b-adc2-28435b13248a ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/15/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0302
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: M11AD
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr0302:bd08/15/2013:svnASUSTeKCOMPUTERINC.:pnM11AD:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnM11AD:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: M11AD
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTeK COMPUTER INC.
  version.compiz: compiz 1:0.9.11.3+14.04.20160425-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1ubuntu0.14.04.2
  version.libgl1-mesa-dri: libgl1-mesa-dri N/A
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
  xserver.bootTime: Wed Feb 21 18:48:14 2018
  xserver.configfile: default
  xserver.errors:

  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:

  xserver.version: 2:1.18.3-1ubuntu2.3~trusty4

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1750937/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to