*** This bug is a duplicate of bug 1751414 ***

** This bug has been marked a duplicate of bug 1751414
   [regression] Missing Wayland login option and missing GL acceleration, after 
installing libegl1

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.

  Upgrading Ubuntu 18.04 disables GPU hardware acceleration

Status in xorg package in Ubuntu:

Bug description:
  I don't know which package causes this problem. The thing is ugrading
  Ubuntu 18.04 disables my GPU hardware acceleration.

  OpenGL vendor string: X.Org
  OpenGL renderer string: Radeon RX 560 Series (POLARIS11 / DRM 3.23.0 / 
4.15.0-10-generic, LLVM 5.0.1)
  OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.3.3

  OpenGL vendor string: VMware, Inc.
  OpenGL renderer string: llvmpipe (LLVM 5.0, 256 bits)
  OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.3.3

  This problem is reproducible.

  Steps to reproduce:
  1. Install Ubuntu 18.04 daily live. I've tried Kubuntu 18.04 Feb 26's daily 
live(the installer in Mar 1 crashes which prevents me from installing it) and 
Xubuntu 18.04 Mar 2's daily live. Ubuntu is utilizing my GPU in live cd session 
and after the fresh install Ubuntu is also utilizing my GPU.
  2. Reboot into the newly installed system, do a dist-upgrade and reboot 
again. Opengl renderer falls back to llvmpipe.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu5
  ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
  Uname: Linux 4.15.0-10-generic x86_64
  ApportVersion: 2.20.8-0ubuntu10
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: XFCE
  Date: Sat Mar  3 00:58:35 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
   Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Polaris11] [1002:67ff] (rev 
cf) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Baffin [Radeon RX 560] [1043:04be]
  InstallationDate: Installed on 2018-03-02 (0 days ago)
  InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180302)
  MachineType: Gigabyte Technology Co., Ltd. B85M-D3V-A
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-10-generic.efi.signed 
root=UUID=d2dcc7eb-84ca-4102-9ae1-239de26d113c ro quiet splash vt.handoff=1
  Renderer: Software
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/12/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F2
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: B85M-D3V-A
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: B85M-D3V-A
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.90-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.3.3-0ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.3.3-0ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to