I also have this problem.
Every time at startup the "No system tray detected" erro message shows up.
I use Ubuntu 17.10 and HPLIP 3.17.11 (last version at the time of writing).

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to hplip in Ubuntu.
https://bugs.launchpad.net/bugs/1714659

Title:
  HPLIP is not compatible with modern GNOME (No system tray detected on
  this system. Unable to start, exiting.)

Status in HPLIP:
  Confirmed
Status in hplip package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Install Ubuntu 17.10
  2. Install hplip-gui
  3. Launch GNOME session.
  4. Get error message window with header "HPLIP Status Service"
  and text
  "No system tray detected on this system.
  Unable to start, exiting."

  Expected results:
  hp-systray is compatible with modern GNOME

  Actual results:
  hp-systray is not compatible with modern GNOME

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: hplip-gui 3.17.7+repack0-3
  ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
  Uname: Linux 4.12.0-11-generic i686
  ApportVersion: 2.20.7-0ubuntu1
  Architecture: i386
  CupsErrorLog: W [01/Sep/2017:17:24:48 +0300] Notifier for subscription 112 
(dbus://) went away, retrying!
  CurrentDesktop: GNOME
  Date: Sat Sep  2 14:10:19 2017
  InstallationDate: Installed on 2017-08-26 (6 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha i386 (20170826)
  Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No 
destinations added.
  MachineType: ASUSTeK COMPUTER INC. UX32A
  PackageArchitecture: all
  Papersize: a4
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.12.0-11-generic 
root=UUID=c2d4f47c-f1c6-4731-b8d0-dc268c6bf996 ro quiet splash vt.handoff=7
  SourcePackage: hplip
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/12/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: UX32A.216
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: UX32A
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrUX32A.216:bd02/12/2014:svnASUSTeKCOMPUTERINC.:pnUX32A:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32A:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.family: UX
  dmi.product.name: UX32A
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hplip/+bug/1714659/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to