I ran into the same problem with 17.10 and I solved it without any fixed
or workarounds. But this is not an ubuntu bug! It's a false
configuration. There are 2 Options for automatic IPv6 configuration in
network manager. "Automatic" and "Automatic (DHCP only)". IPv6 router
advertisment is not part of dhcpv6 by spec! So I switch my config to
"Automatic" which uses dhcpv6 and router advertisment. The kernel option
/proc/sys/net/ipv6/conf/ethX/accept_ra is set to 1 (active) then!
Problem solved!

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to network-manager in Ubuntu.

  dhcp IPv6 sets accept_ra to 0 and doesn't get IPv6 route

Status in network-manager package in Ubuntu:

Bug description:
  Configure IPv6 network so that the IP address is obtained through
  DHCPv6 and setup NetworkManager IPv6 to use the "Automatic (DHCP
  only)" method.   accept_ra is then set to 0 and NetworkManager fails
  to obtain the IPv6 route.

  Attached is a script /etc/NetworkManager/dispatcher.d/02allowIPv6route
  which works around the issue to set accept_ra to 1.

  I am running Kubuntu 13.04, but I believe the bug is not limited to
  this release.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to