Can confirm that this is fixed in 17.10. When I close the lid of my
computer and it suspends, the screen is an "unlock" screen.

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gnome-shell in Ubuntu.
https://bugs.launchpad.net/bugs/1753884

Title:
   session logout after suspend

Status in gnome-shell package in Ubuntu:
  New

Bug description:
  Only when I have a second monitor plugged in, if I close the lid of my
  laptop, my session gets logged out. What I'm expecting is the lock
  screen comes up.

  Sometimes (but not always) the second monitor will flash the "logged
  out" screen for a second or two before going dim.

  I have "Suspend even if external monitor is plugged in" enabled in
  Tweak Tools.

  WORKAROUND: Suspend via the GUI with the lid open.

  WORKAROUND: Unplug the second monitor before closing the lid.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.13.0-36.40~16.04.1-generic 4.13.13
  Uname: Linux 4.13.0-36-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.15
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: GNOME
  Date: Tue Mar  6 18:07:50 2018
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] 
(rev 0b) (prog-if 00 [VGA controller])
     Subsystem: Lenovo Haswell-ULT Integrated Graphics Controller [17aa:220c]
  InstallationDate: Installed on 2018-02-15 (19 days ago)
  InstallationMedia: Ubuntu-GNOME 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
  MachineType: LENOVO 20AQ009HUS
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-36-generic 
root=UUID=6f20d80f-81f4-40c1-aafd-95b2c5de55ed ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/29/2014
  dmi.bios.vendor: LENOVO
  dmi.bios.version: GJET78WW (2.28 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20AQ009HUS
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50510 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvrGJET78WW(2.28):bd07/29/2014:svnLENOVO:pn20AQ009HUS:pvrThinkPadT440s:rvnLENOVO:rn20AQ009HUS:rvrSDK0E50510WIN:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.family: ThinkPad T440s
  dmi.product.name: 20AQ009HUS
  dmi.product.version: ThinkPad T440s
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.83-1~16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.8-0ubuntu0~16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.8-0ubuntu0~16.04.1
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1753884/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to