** Also affects: linux (Ubuntu)
   Importance: Undecided
       Status: New

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to pulseaudio in Ubuntu.

  Periodic glitch in sound with Firewire and snd-dice

Status in linux package in Ubuntu:
Status in pulseaudio package in Ubuntu:

Bug description:
  I have a fresh installation of Ubuntu 17.10 with almost nothing extra
  installed yet besides Bitwig Studio, Cadence and a few other things
  from the KX Studio repositories.

  But I also tried the bug after a fresh install with nothing else than
  Bitwig Studio installed, it's the same.

  I have a TC Electronics Impact Twin Firewire audio interface.
  It is connected to a Iocrest SY-PEX30016 PCI-E card, which has a Texas 
Instruments XIO2213BZAY chipset.

  The ALSA snd-dice drivers work, but with glitches.

  There is a periodic, glitch in the sound that sounds like a part of the 
stream is missing, or something. It is steady in timing, nothing seems to have 
an effect on it.
  Recording seems to work. All outputs and inputs, also the ADAT outputs seem 
to work, altough I could not test if the ADAT outputs feature the glitch too.

  Seemingly randomly there might be a short maybe around 0.3 second
  total break in the sound.

  I'm not getting xruns at all.

  I tried also Ubuntu Studio live USB, it has the exact same glitch. I
  also tried a Native Instruments Audio2DJ USB interface, with that
  there is no problem with the sound on my computer.

  I tried also with Carla and ZynAddSubFx, and also with the live USB of
  Linux Mint (current version), and the same glitch is present.

  I tried also another Firewire controller card with a XIO2200A Texas
  Instruments chip, it features the same glitch, but running a different

  I had a KX Studio 14.x installation a few years ago, where the
  interface was working without a hitch. But then I was running with

  So to me it seems that the kernel integration of snd-dice has some
  problem with timing with a TC Electronics interface?

  I could not get FFADO to run with Jack now so I can't say if the FFADO
  implementation would work.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: pulseaudio 1:10.0-2ubuntu3.1
  ProcVersionSignature: Ubuntu 4.13.0-36.40-generic 4.13.13
  Uname: Linux 4.13.0-36-generic x86_64
  ApportVersion: 2.20.7-0ubuntu3.7
  Architecture: amd64
   /dev/snd/pcmC4D0c:   kim        3563 F...m jackdbus
   /dev/snd/pcmC4D0p:   kim        3563 F...m jackdbus
   /dev/snd/controlC4:  kim        3563 F.... jackdbus
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Mar 13 02:11:51 2018
  InstallationDate: Installed on 2018-03-12 (0 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105.1)
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  SourcePackage: pulseaudio
  Symptom: audio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/12/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2603
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: M5A97 EVO R2.0
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: To be filled by O.E.M.
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: To be filled by O.E.M.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to