** Information type changed from Private to Public

** Also affects: hplip
   Importance: Undecided
       Status: New

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to hplip in Ubuntu.
https://bugs.launchpad.net/bugs/1755340

Title:
  toolbox.py crashed with SIGABRT in qt_message_fatal()

Status in HPLIP:
  New
Status in hplip package in Ubuntu:
  New

Bug description:
  I tried this time compiling hplip with qt5 support and no qt4 support trying 
to force the use of qt5.
  I have previously installed qt-opensource-linux-x64-5.9.4 and even then the 
installer complains about the lack of Python-Qt5.
  The problem is that the names listed in the installer report do not match the 
package names in the Ubuntu repositories and this has been a long time and has 
never been healed.
  To solve this problem, I tried to install via synaptic manager all the 
python-pyqt5 of the repositories, python something dbus and even then 
complained about the lack of Python-Qt5.
  After some more research and to reread the report I decided to download and 
install from the Ubuntu repository these files:
  libqt5core5a_5.9.4 + dfsg-0ubuntu3_amd64.deb, python-olefile_0.44-1_all.deb,
  libqt5dbus5_5.9.4 + dfsg-0ubuntu3_amd64.deb, 
python-pil_4.1.1-3build2_amd64.deb,
  python-imaging_4.1.1-3build2_all.deb
  A combination of these files, others I had already installed as I mentioned 
earlier using the synaptic manager and the previous installation of Qt5 Creator 
resolved the conflict and I was able to compile manually with the options 
without qt4 support, no documents installed, no network and no support fax 
machine installed.
  Unfortunately when I finished the compilation and since it had been the 
launcher of the previous installation it did not boot. I had to launch 
hp-toolbox from the terminal and new error messages appeared.
  After intense search for internet dropping in forums most of them on 
programming in C or python I discovered that I need to give more these 3 
commands every session that I initiate for hp-toolbox to work, since neither in 
the LXDE interface it adds to systray like it does when it is not compiled with 
Qt5 support only.
  The commands are:
  export LD_LIBRARY_PATH = / usr / lib / x86_64-linux-gnu / qt5 / Tools / 
QtCreator / lib / Qt / lib
  export QT_LIBRARY_PATH = / usr / lib / x86_64-linux-gnu / qt5 / Tools / 
QtCreator / lib / Qt / lib
  export QT_PLUGIN_PATH = / usr / lib / x86_64-linux-gnu / qt5 / Tools / 
QtCreator / lib / Qt / plugins
  Although the interface does open, it still has an error message about the 
lack of Python 2.3+ and that the fax support was turned off.
  Very strange because the hp-check report and the hp-doctor report did not 
report any missing dependencies.
  I recompiled again with the same values ​​except for enabling fax support and 
believe it or not, without this misery gives an error that does not correspond 
to reality.
  However it follows the same problem in the LXDE interface it does not 
initialize by the launcher, having to open by the terminal and it does not stay 
in the tray.
  In Gnome the HD Device Manager has never been on the tray since a long time 
and is something that has never been solved.

  ProblemType: Crash
  DistroRelease: Ubuntu 18.04
  Uname: Linux 4.16.0-997-generic x86_64
  ApportVersion: 2.20.8-0ubuntu10
  Architecture: amd64
  CrashCounter: 1
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Mar 12 23:07:56 2018
  Dependencies:
   gcc-8-base 8-20180218-1ubuntu1
   libc6 2.27-0ubuntu2
   libgcc1 1:8-20180218-1ubuntu1
   liblzma5 5.2.2-1.3
   xz-utils 5.2.2-1.3
  ExecutablePath: /usr/share/hplip/toolbox.py
  InterpreterPath: /usr/bin/python2.7
  JournalErrors:
   Error: command ['journalctl', '-b', '--priority=err', '--lines=1000'] failed 
with exit code 1: Hint: You are currently not seeing messages from other users 
and the system.
         Users in the 'systemd-journal' group can see all messages. Pass -q to
         turn off this notice.
   No journal files were opened due to insufficient permissions.
  Lpstat: device for Deskjet-F4100-series: 
hp:/usb/Deskjet_F4100_series?serial=BR85LG1F4F04TJ
  MachineType: Acer V5-171
  PackageArchitecture: all
  Papersize: a4
  PpdFiles: Error: command ['fgrep', '-H', '*NickName', 
'/etc/cups/ppd/Deskjet-F4100-series.ppd'] failed with exit code 2: grep: 
/etc/cups/ppd/Deskjet-F4100-series.ppd: Permission denied
  ProcCmdline: python /usr/bin/hp-toolbox
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.16.0-997-generic 
root=UUID=65779dc8-aafc-45ab-bbc0-76120e38e060 ro quiet splash vt.handoff=1
  Python3Details: /usr/bin/python3.6, Python 3.6.4+, python3-minimal, 3.6.4-1
  PythonDetails: /usr/bin/python2.7, Python 2.7.14+, python-minimal, 2.7.14-4
  Signal: 6
  SourcePackage: hplip
  StacktraceTop:
   QMessageLogger::fatal(char const*, ...) const () from 
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5
   QGuiApplicationPrivate::createPlatformIntegration() () from 
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
   QGuiApplicationPrivate::createEventDispatcher() () from 
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
   QCoreApplicationPrivate::init() () from 
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5
   QGuiApplicationPrivate::init() () from 
/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
  Title: toolbox.py crashed with SIGABRT in QMessageLogger::fatal()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin netdev plugdev sambashare sudo
  dmi.bios.date: 11/26/2013
  dmi.bios.vendor: Acer
  dmi.bios.version: V2.21
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: Mimic
  dmi.board.vendor: Acer
  dmi.board.version: Type2 - Board Version
  dmi.chassis.type: 10
  dmi.chassis.vendor: Acer
  dmi.chassis.version: V2.21
  dmi.modalias: 
dmi:bvnAcer:bvrV2.21:bd11/26/2013:svnAcer:pnV5-171:pvrV2.21:rvnAcer:rnMimic:rvrType2-BoardVersion:cvnAcer:ct10:cvrV2.21:
  dmi.product.family: Type1Family
  dmi.product.name: V5-171
  dmi.product.version: V2.21
  dmi.sys.vendor: Acer

To manage notifications about this bug go to:
https://bugs.launchpad.net/hplip/+bug/1755340/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to