Thank you for taking the time to report this bug and helping to make Ubuntu 
better. We are sorry that we do not always have the capacity to look at all 
reported bugs in a timely manner. There have been many changes in Ubuntu since 
that time you reported the bug and your problem may have been fixed with some 
of the updates. It would help us a lot if you could test it on a currently 
supported Ubuntu version. If you test it and it is still an issue, kindly 
upload the updated logs by running only once:
apport-collect 1310392

and any other logs that are relevant for this particular issue.

** Changed in: nvidia-graphics-drivers-173 (Ubuntu)
       Status: New => Incomplete

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to nvidia-graphics-drivers-173 in Ubuntu.
https://bugs.launchpad.net/bugs/1310392

Title:
  Hardware screen scaling problems since 14.04 upgrade with Nvidia
  legacy driver

Status in nvidia-graphics-drivers-173 package in Ubuntu:
  Incomplete

Bug description:
  Hello,

  Just upgraded to Lubuntu 32-bit 14.04 from 13.10 on April 18th, 2014.

  - System is a P4, 2.8Ghz, 3GB RAM,
  - NVidia GeForce 5700LE AGP graphics card with proprietary legacy video 
drivers manually installed from Nvidia site (VERSION 173.14.39, RELEASE: 
2013.12.6 - the latest possible version available for my graphics card).
  - Motherboard is ASUS P4P800-E upgraded to the latest BIOS available.

  Prior to the upgrade, the arcade emulator MAME, the Commodore 64
  emulator VICE, and the Commodore Amiga emulator FS-UAE worked
  fantastically in full screen scaled mode. No delay, smooth
  performance. Reasonably low CPU usage for a processor of this vintage.

  After the upgrade to 14.04, all full screen modes (1080x1920) in these
  emulators bring the system to a crawl. Sound from the emulator is
  broken up, framerates are terrible (like two frames a second), CPU
  usage is near or past 100%. I suspect other OpenGL software using
  full-screen scaling would also be affected, but these are the only
  three pieces of software I have to test with.

  I've found that in MAME and VICE, I can work-around this problem but
  shutting off "hardware scaling". Essentially (I think), this takes my
  graphics card out of the loop and does the scaling in software/CPU.
  Scaling down the resolution of the emulation helps too. Frame-rates
  are better, CPU usage is lower by a factor of 30 to 40%. However,
  because of these "work around measure" the overall user experience of
  the emulators is severely impeded.

  I also ran glxgears as a test and resized the window from its original
  small size, a little bigger every five seconds, until it was the full
  height of the screen (1080 lines) and got the following results:

  Code:

  brent@Brent-Lubuntu:~$ glxgears
  552 frames in 5.0 seconds = 110.342 FPS
  593 frames in 5.0 seconds = 118.471 FPS
  416 frames in 5.0 seconds = 83.071 FPS
  315 frames in 5.0 seconds = 62.810 FPS
  287 frames in 5.0 seconds = 57.252 FPS
  197 frames in 5.0 seconds = 39.354 FPS
  165 frames in 5.0 seconds = 32.789 FPS
  130 frames in 5.0 seconds = 25.937 FPS
  124 frames in 5.0 seconds = 24.781 FPS
  117 frames in 5.0 seconds = 23.274 FPS
  XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
        after 25689 requests (25666 known processed) with 0 events remaining.

  I had originally switched to the Nvidia proprietary driver from
  Nouveau because of slight artifacts and stuttering in the latter. The
  proprietary driver mentioned above worked like a dream in 13.10.

  MP4 videos played in VLC VideoLAN player still play well, with low CPU
  usage.

  Based on my limited knowledge, this seems to be a problem with the
  graphics card full-screen scaling to 1080x1920 (desktop & monitor
  screenmode) under 14.04. Might have to do something with OpenGL?

  The system works very well, other than when these emulators try to go
  into full screen mode.

  My Xorg.0.log file shows the following (notice the error lines):

  (II) LoadModule: "nvidia"
  (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
  (II) Module nvidia: vendor="NVIDIA Corporation"
  compiled for 4.0.2, module version = 1.0.0
  Module class: X.Org Video Driver
  (II) NVIDIA dlloader X Driver 173.14.39 Wed Nov 27 15:02:30 PST 2013
  (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

  ...

  (**) NVIDIA(0): Enabling RENDER acceleration
  (EE) NVIDIA(0): Failed to initialize the GLX module; please check in
  your X
  (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
  (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX
  module. If
  (EE) NVIDIA(0): you continue to encounter problems, Please try
  (EE) NVIDIA(0): reinstalling the NVIDIA driver.
  (II) NVIDIA(0): NVIDIA GPU GeForce FX 5700LE (NV36) at PCI:1:0:0 (GPU-0)
  (--) NVIDIA(0): Memory: 262144 kBytes
  (--) NVIDIA(0): VideoBIOS: 04.36.20.35.00
  (II) NVIDIA(0): Detected AGP rate: 8X
  (--) NVIDIA(0): Interlaced video modes are supported on this GPU
  (--) NVIDIA(0): Connected display device(s) on GeForce FX 5700LE at
  (--) NVIDIA(0): PCI:1:0:0:
  (--) NVIDIA(0): Samsung SMBX2240 (CRT-0)
  (--) NVIDIA(0): Samsung SMBX2240 (CRT-0): 400.0 MHz maximum pixel clock

  It couldn't initialize opengl with Trusty Tahr 14.04.

  One way of duplicating this bug (if you are using an NVidia legacy
  driver and graphics card):

  1. Install the latest version of the VICE emulator
  2. from terminal type XVIC
  3. Under SETTINGS/VIC SETTINGS/ menu, ensure that HARDWARE SCALING is checked
  4. start a graphically intensive game (i.e. the GORF cartridge or a 
shoot-em-up game).
  5. Press CTRL-D to engage full-screen mode.
  6. CPU usage will be very high compared with HARDWARE SCALING unchecked.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173/+bug/1310392/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to