I installed libblockdev-crypto2, and now I don't get the error "function
bd_crypto_luks_open_blob called but not implemented" - but I now instead
get an "Operation not permitted" error. Does anyone else have this
issue? My external disk is btrfs formatted, but that shouldn't be the
cause, I get the same error even if I put the wrong password in so it
seems like it's getting denied somewhere before it can even try to
decrypt the disk.

** Attachment added: "Screenshot from 2018-04-08 16-34-12.png"

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to udisks2 in Ubuntu.

  udisks2 must depend on libblockdev-crypto2 and libblockdev-mdraid2
  instead of suggests [Can't mount encrypted USB drive after upgrade to

Status in udisks2 package in Ubuntu:

Bug description:
  after upgrading to bionic, attempts to mount an encrypted USB drive
  fail with the error "function bd_crypto_luks_open_blob called but not

  Installing libblockdev-crypto2 and libblockdev-crypto-dev and
  rebooting appears to have fixed it, but should that be necessary?  or
  at least better documented?
  (https://www.distrowatch.com/weekly.php?issue=20171113 is the only
  reference I could find on the error)

  1. Install libblockdev-crypto2
  2. Restart udisks:
    $ systemctl restart udisks2

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: udisks2 2.7.6-2ubuntu4
  ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
  Uname: Linux 4.15.0-12-generic x86_64
  ApportVersion: 2.20.8-0ubuntu10
  Architecture: amd64
  CurrentDesktop: GNOME
  CustomUdevRuleFiles: 90-xhc_sleep.rules 70-snap.core.rules
  Date: Tue Mar 20 20:28:39 2018
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2015-08-21 (942 days ago)
  InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150819)
  MachineType: Apple Inc. MacBookPro11,4
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-12-generic.efi.signed 
root=/dev/mapper/ubuntu--gnome--vg-root ro quiet splash vt.handoff=1
  SourcePackage: udisks2
  UpgradeStatus: Upgraded to bionic on 2018-03-20 (0 days ago)
  dmi.bios.date: 06/05/2015
  dmi.bios.vendor: Apple Inc.
  dmi.bios.version: MBP114.88Z.0172.B04.1506051511
  dmi.board.name: Mac-06F11FD93F0323C5
  dmi.board.vendor: Apple Inc.
  dmi.board.version: MacBookPro11,4
  dmi.chassis.type: 9
  dmi.chassis.vendor: Apple Inc.
  dmi.chassis.version: Mac-06F11FD93F0323C5
  dmi.product.family: MacBook Pro
  dmi.product.name: MacBookPro11,4
  dmi.product.version: 1.0
  dmi.sys.vendor: Apple Inc.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to