Public bug reported:

Fresh install of 18.04 Beta final on HP Pavilion G6 laptop.


Selected 'install proprietary drivers and codecs' during installation.

Wifi worked on first boot.

Performed apt update && apt upgrade.

On second boot after updates, wifi will not connect. Tried three
separate access points, to no avail.

Workaround was to disable proprietary driver.

Submitted as bug, as new user would struggle. network-manager should not
set a non-working wifi driver as default.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: network-manager 1.10.6-2ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Apr 11 11:45:44 2018
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2018-04-11 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Beta amd64 (20180404)
IpRoute:
 default via 192.168.0.1 dev wlp1s0b1 proto dhcp metric 600 
 192.168.0.0/24 dev wlp1s0b1 proto kernel scope link src 192.168.0.31 metric 600
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE    TYPE      STATE        DBUS-PATH                                  
CONNECTION  CON-UUID                              CON-PATH                      
                     
 wlp1s0b1  wifi      connected    /org/freedesktop/NetworkManager/Devices/3  
VM7710976   178e1867-9364-4de8-a595-91f81268dbc7  
/org/freedesktop/NetworkManager/ActiveConnection/2 
 eno1      ethernet  unavailable  /org/freedesktop/NetworkManager/Devices/2  -- 
         --                                    --                               
                  
 lo        loopback  unmanaged    /org/freedesktop/NetworkManager/Devices/1  -- 
         --                                    --
nmcli-nm:
 RUNNING  VERSION  STATE      STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  WIFI  
   WWAN-HW  WWAN    
 running  1.10.6   connected  started  full          enabled     enabled  
enabled  enabled  enabled

** Affects: network-manager (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug bionic

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1762996

Title:
  network-manager sets proprietary driver as default, which breaks wifi

Status in network-manager package in Ubuntu:
  New

Bug description:
  Fresh install of 18.04 Beta final on HP Pavilion G6 laptop.

  
  Selected 'install proprietary drivers and codecs' during installation.

  Wifi worked on first boot.

  Performed apt update && apt upgrade.

  On second boot after updates, wifi will not connect. Tried three
  separate access points, to no avail.

  Workaround was to disable proprietary driver.

  Submitted as bug, as new user would struggle. network-manager should
  not set a non-working wifi driver as default.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: network-manager 1.10.6-2ubuntu1
  ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
  Uname: Linux 4.15.0-13-generic x86_64
  ApportVersion: 2.20.9-0ubuntu4
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Apr 11 11:45:44 2018
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2018-04-11 (0 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Beta amd64 (20180404)
  IpRoute:
   default via 192.168.0.1 dev wlp1s0b1 proto dhcp metric 600 
   192.168.0.0/24 dev wlp1s0b1 proto kernel scope link src 192.168.0.31 metric 
600
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  ProcEnviron:
   LANGUAGE=en_GB:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_GB.UTF-8
   SHELL=/bin/bash
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-dev:
   DEVICE    TYPE      STATE        DBUS-PATH                                  
CONNECTION  CON-UUID                              CON-PATH                      
                     
   wlp1s0b1  wifi      connected    /org/freedesktop/NetworkManager/Devices/3  
VM7710976   178e1867-9364-4de8-a595-91f81268dbc7  
/org/freedesktop/NetworkManager/ActiveConnection/2 
   eno1      ethernet  unavailable  /org/freedesktop/NetworkManager/Devices/2  
--          --                                    --                            
                     
   lo        loopback  unmanaged    /org/freedesktop/NetworkManager/Devices/1  
--          --                                    --
  nmcli-nm:
   RUNNING  VERSION  STATE      STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI     WWAN-HW  WWAN    
   running  1.10.6   connected  started  full          enabled     enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1762996/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to