Public bug reported:

Steps to Reproduce:
* Open Evolution
* Browse to an email in an IMAP inbox (Gmail)
* Press "Reply to All", "Reply to Sender", and "Forward"

Behavior Observed:
* A composer window is opened with the correct address and subject for a Reply 
or Forward. If Forward, then attachments are included.
* No text is included. Even if text is highlighted in the original email, it 
will not be included.
* Copying and pasting text from the previous email into the new composer window 
has no effect.
* Typing in the composer window works as expected.
* Text is not quoted from HTML or Plain Text emails.

Behavior Expected:
* Text in the previous email should be included in the composer window in a 
quoted or inline format.

Environment:
* Evolution 3.28.1-1
* Ubuntu 18.04 Beta, Ubuntu Bionic Beaver (development branch)

Note:
* I have configured Evolution to always respond with Plain Text emails, 
including losing formatting from HTML emails.
* It worked on April 11 until I performed an upgrade. It was immediately broken 
afterward.

Start-Date: 2018-04-11  21:47:18
Commandline: apt upgrade
Requested-By: richard (1000)
Install: python3-olefile:amd64 (0.45.1-1, automatic), 
gnome-startup-applications:amd64 (3.28.1-0ubuntu1, automatic)
Upgrade: evince:amd64 (3.28.0-1, 3.28.2-1), libsoup-gnome2.4-1:amd64 (2.62.0-1, 
2.62.1-1), evolution-data-server-common:amd64 (3.28.0-2ubuntu2, 
3.28.1-1ubuntu1), libvte-2.91-0:amd64 (0.52.0-1ubuntu2, 0.52.1-1ubuntu1), 
libedataserverui-1.2-2:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), libcups2:amd64 
(2.2.7-1ubuntu1, 2.2.7-1ubuntu2), kdeconnect:amd64 (1.2.1-0ubuntu2, 
1.3.0-0ubuntu1), gnome-session-common:amd64 (3.28.0-0ubuntu3, 3.28.1-0ubuntu1), 
libevdocument3-4:amd64 (3.28.0-1, 3.28.2-1), vim-common:amd64 
(2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), gir1.2-soup-2.4:amd64 (2.62.0-1, 
2.62.1-1), python3-software-properties:amd64 (0.96.24.26, 0.96.24.27), 
libdw1:amd64 (0.170-0.3, 0.170-0.4), gnome-user-docs:amd64 
(3.28.0+git20180331-0ubuntu1, 3.28.1-0ubuntu1), update-notifier-common:amd64 
(3.189, 3.190), libelf1:amd64 (0.170-0.3, 0.170-0.4), binutils:amd64 
(2.30-14ubuntu2, 2.30-15ubuntu1), language-selector-common:amd64 (0.186, 
0.187), libunity-protocol-private0:amd64 (7.1.4+18.04.20180209.1-0ubuntu1, 
7.1.4+18.04.20180209.1-0ubuntu2), ubuntu-standard:amd64 (1.414, 1.415), 
python3-pil:amd64 (5.0.0-1, 5.1.0-1), ubuntu-session:amd64 (3.28.0-0ubuntu3, 
3.28.1-0ubuntu1), gir1.2-unity-5.0:amd64 (7.1.4+18.04.20180209.1-0ubuntu1, 
7.1.4+18.04.20180209.1-0ubuntu2), ubuntu-desktop:amd64 (1.414, 1.415), 
gdb:amd64 (8.1-0ubuntu2, 8.1-0ubuntu3), virtualbox-dkms:amd64 (5.2.8-dfsg-5, 
5.2.8-dfsg-6), evolution-common:amd64 (3.28.0-4, 3.28.1-1), 
cups-server-common:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), 
evolution-data-server:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
kio-extras:amd64 (4:17.12.3-0ubuntu1, 4:17.12.3-0ubuntu2), 
libdazzle-1.0-0:amd64 (3.28.0-1, 3.28.1-1), cups-common:amd64 (2.2.7-1ubuntu1, 
2.2.7-1ubuntu2), software-properties-gtk:amd64 (0.96.24.26, 0.96.24.27), 
virtualbox:amd64 (5.2.8-dfsg-5, 5.2.8-dfsg-6), libsoup2.4-1:amd64 (2.62.0-1, 
2.62.1-1), gnome-disk-utility:amd64 (3.28.0-1ubuntu1, 3.28.1-0ubuntu1), 
gnome-user-guide:amd64 (3.28.0+git20180331-0ubuntu1, 3.28.1-0ubuntu1), 
binutils-x86-64-linux-gnu:amd64 (2.30-14ubuntu2, 2.30-15ubuntu1), 
ubuntu-minimal:amd64 (1.414, 1.415), evolution-plugin-bogofilter:amd64 
(3.28.0-4, 3.28.1-1), libinput-bin:amd64 (1.10.3-2, 1.10.4-1), 
libebackend-1.2-10:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
evince-common:amd64 (3.28.0-1, 3.28.2-1), libebook-1.2-19:amd64 
(3.28.0-2ubuntu2, 3.28.1-1ubuntu1), cups-ppdc:amd64 (2.2.7-1ubuntu1, 
2.2.7-1ubuntu2), gir1.2-vte-2.91:amd64 (0.52.0-1ubuntu2, 0.52.1-1ubuntu1), 
libcupsmime1:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libevview3-3:amd64 
(3.28.0-1, 3.28.2-1), evolution-plugin-pstimport:amd64 (3.28.0-4, 3.28.1-1), 
vim-runtime:amd64 (2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), libunity9:amd64 
(7.1.4+18.04.20180209.1-0ubuntu1, 7.1.4+18.04.20180209.1-0ubuntu2), 
zenity:amd64 (3.28.0-1, 3.28.1-1), vim:amd64 (2:8.0.1401-1ubuntu3, 
2:8.0.1453-1ubuntu1), libwebkit2gtk-4.0-37:amd64 (2.20.0-2ubuntu1, 2.20.1-1), 
xxd:amd64 (2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), vim-gui-common:amd64 
(2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), binutils-common:amd64 
(2.30-14ubuntu2, 2.30-15ubuntu1), gnome-session-bin:amd64 (3.28.0-0ubuntu3, 
3.28.1-0ubuntu1), libvte-2.91-common:amd64 (0.52.0-1ubuntu2, 0.52.1-1ubuntu1), 
libcupsppdc1:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libbinutils:amd64 
(2.30-14ubuntu2, 2.30-15ubuntu1), libebook-contacts-1.2-2:amd64 
(3.28.0-2ubuntu2, 3.28.1-1ubuntu1), gir1.2-webkit2-4.0:amd64 (2.20.0-2ubuntu1, 
2.20.1-1), vim-gtk3:amd64 (2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), 
libedata-book-1.2-25:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
virtualbox-qt:amd64 (5.2.8-dfsg-5, 5.2.8-dfsg-6), vim-tiny:amd64 
(2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), gdbserver:amd64 (8.1-0ubuntu2, 
8.1-0ubuntu3), libedata-cal-1.2-28:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
cups-bsd:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), cups-core-drivers:amd64 
(2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libunity-scopes-json-def-desktop:amd64 
(7.1.4+18.04.20180209.1-0ubuntu1, 7.1.4+18.04.20180209.1-0ubuntu2), 
cups-daemon:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), kio-extras-data:amd64 
(4:17.12.3-0ubuntu1, 4:17.12.3-0ubuntu2), language-selector-gnome:amd64 (0.186, 
0.187), libcamel-1.2-61:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
libcupsimage2:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libecal-1.2-19:amd64 
(3.28.0-2ubuntu2, 3.28.1-1ubuntu1), evolution-plugins:amd64 (3.28.0-4, 
3.28.1-1), cups:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libcupscgi1:amd64 
(2.2.7-1ubuntu1, 2.2.7-1ubuntu2), cups-client:amd64 (2.2.7-1ubuntu1, 
2.2.7-1ubuntu2), libjavascriptcoregtk-4.0-18:amd64 (2.20.0-2ubuntu1, 2.20.1-1), 
cups-ipp-utils:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), patch:amd64 (2.7.6-1, 
2.7.6-2ubuntu1), update-notifier:amd64 (3.189, 3.190), 
libedataserver-1.2-23:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
zenity-common:amd64 (3.28.0-1, 3.28.1-1), gnome-getting-started-docs:amd64 
(3.28.0+git20180331-0ubuntu1, 3.28.1-0ubuntu1), libevolution:amd64 (3.28.0-4, 
3.28.1-1), evolution:amd64 (3.28.0-4, 3.28.1-1), 
gir1.2-javascriptcoregtk-4.0:amd64 (2.20.0-2ubuntu1, 2.20.1-1), 
libinput10:amd64 (1.10.3-2, 1.10.4-1), base-files:amd64 (10ubuntu1, 
10.1ubuntu1), software-properties-common:amd64 (0.96.24.26, 0.96.24.27)
End-Date: 2018-04-11  21:48:23

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: evolution 3.28.1-1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Apr 12 18:17:44 2018
ExecutablePath: /usr/bin/evolution
InstallationDate: Installed on 2018-03-31 (12 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180331)
ProcEnviron:
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: evolution
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: evolution (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug bionic

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to evolution in Ubuntu.
https://bugs.launchpad.net/bugs/1763546

Title:
  No text quoted in a reply or forward

Status in evolution package in Ubuntu:
  New

Bug description:
  Steps to Reproduce:
  * Open Evolution
  * Browse to an email in an IMAP inbox (Gmail)
  * Press "Reply to All", "Reply to Sender", and "Forward"

  Behavior Observed:
  * A composer window is opened with the correct address and subject for a 
Reply or Forward. If Forward, then attachments are included.
  * No text is included. Even if text is highlighted in the original email, it 
will not be included.
  * Copying and pasting text from the previous email into the new composer 
window has no effect.
  * Typing in the composer window works as expected.
  * Text is not quoted from HTML or Plain Text emails.

  Behavior Expected:
  * Text in the previous email should be included in the composer window in a 
quoted or inline format.

  Environment:
  * Evolution 3.28.1-1
  * Ubuntu 18.04 Beta, Ubuntu Bionic Beaver (development branch)

  Note:
  * I have configured Evolution to always respond with Plain Text emails, 
including losing formatting from HTML emails.
  * It worked on April 11 until I performed an upgrade. It was immediately 
broken afterward.

  Start-Date: 2018-04-11  21:47:18
  Commandline: apt upgrade
  Requested-By: richard (1000)
  Install: python3-olefile:amd64 (0.45.1-1, automatic), 
gnome-startup-applications:amd64 (3.28.1-0ubuntu1, automatic)
  Upgrade: evince:amd64 (3.28.0-1, 3.28.2-1), libsoup-gnome2.4-1:amd64 
(2.62.0-1, 2.62.1-1), evolution-data-server-common:amd64 (3.28.0-2ubuntu2, 
3.28.1-1ubuntu1), libvte-2.91-0:amd64 (0.52.0-1ubuntu2, 0.52.1-1ubuntu1), 
libedataserverui-1.2-2:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), libcups2:amd64 
(2.2.7-1ubuntu1, 2.2.7-1ubuntu2), kdeconnect:amd64 (1.2.1-0ubuntu2, 
1.3.0-0ubuntu1), gnome-session-common:amd64 (3.28.0-0ubuntu3, 3.28.1-0ubuntu1), 
libevdocument3-4:amd64 (3.28.0-1, 3.28.2-1), vim-common:amd64 
(2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), gir1.2-soup-2.4:amd64 (2.62.0-1, 
2.62.1-1), python3-software-properties:amd64 (0.96.24.26, 0.96.24.27), 
libdw1:amd64 (0.170-0.3, 0.170-0.4), gnome-user-docs:amd64 
(3.28.0+git20180331-0ubuntu1, 3.28.1-0ubuntu1), update-notifier-common:amd64 
(3.189, 3.190), libelf1:amd64 (0.170-0.3, 0.170-0.4), binutils:amd64 
(2.30-14ubuntu2, 2.30-15ubuntu1), language-selector-common:amd64 (0.186, 
0.187), libunity-protocol-private0:amd64 (7.1.4+18.04.20180209.1-0ubuntu1, 
7.1.4+18.04.20180209.1-0ubuntu2), ubuntu-standard:amd64 (1.414, 1.415), 
python3-pil:amd64 (5.0.0-1, 5.1.0-1), ubuntu-session:amd64 (3.28.0-0ubuntu3, 
3.28.1-0ubuntu1), gir1.2-unity-5.0:amd64 (7.1.4+18.04.20180209.1-0ubuntu1, 
7.1.4+18.04.20180209.1-0ubuntu2), ubuntu-desktop:amd64 (1.414, 1.415), 
gdb:amd64 (8.1-0ubuntu2, 8.1-0ubuntu3), virtualbox-dkms:amd64 (5.2.8-dfsg-5, 
5.2.8-dfsg-6), evolution-common:amd64 (3.28.0-4, 3.28.1-1), 
cups-server-common:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), 
evolution-data-server:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
kio-extras:amd64 (4:17.12.3-0ubuntu1, 4:17.12.3-0ubuntu2), 
libdazzle-1.0-0:amd64 (3.28.0-1, 3.28.1-1), cups-common:amd64 (2.2.7-1ubuntu1, 
2.2.7-1ubuntu2), software-properties-gtk:amd64 (0.96.24.26, 0.96.24.27), 
virtualbox:amd64 (5.2.8-dfsg-5, 5.2.8-dfsg-6), libsoup2.4-1:amd64 (2.62.0-1, 
2.62.1-1), gnome-disk-utility:amd64 (3.28.0-1ubuntu1, 3.28.1-0ubuntu1), 
gnome-user-guide:amd64 (3.28.0+git20180331-0ubuntu1, 3.28.1-0ubuntu1), 
binutils-x86-64-linux-gnu:amd64 (2.30-14ubuntu2, 2.30-15ubuntu1), 
ubuntu-minimal:amd64 (1.414, 1.415), evolution-plugin-bogofilter:amd64 
(3.28.0-4, 3.28.1-1), libinput-bin:amd64 (1.10.3-2, 1.10.4-1), 
libebackend-1.2-10:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
evince-common:amd64 (3.28.0-1, 3.28.2-1), libebook-1.2-19:amd64 
(3.28.0-2ubuntu2, 3.28.1-1ubuntu1), cups-ppdc:amd64 (2.2.7-1ubuntu1, 
2.2.7-1ubuntu2), gir1.2-vte-2.91:amd64 (0.52.0-1ubuntu2, 0.52.1-1ubuntu1), 
libcupsmime1:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libevview3-3:amd64 
(3.28.0-1, 3.28.2-1), evolution-plugin-pstimport:amd64 (3.28.0-4, 3.28.1-1), 
vim-runtime:amd64 (2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), libunity9:amd64 
(7.1.4+18.04.20180209.1-0ubuntu1, 7.1.4+18.04.20180209.1-0ubuntu2), 
zenity:amd64 (3.28.0-1, 3.28.1-1), vim:amd64 (2:8.0.1401-1ubuntu3, 
2:8.0.1453-1ubuntu1), libwebkit2gtk-4.0-37:amd64 (2.20.0-2ubuntu1, 2.20.1-1), 
xxd:amd64 (2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), vim-gui-common:amd64 
(2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), binutils-common:amd64 
(2.30-14ubuntu2, 2.30-15ubuntu1), gnome-session-bin:amd64 (3.28.0-0ubuntu3, 
3.28.1-0ubuntu1), libvte-2.91-common:amd64 (0.52.0-1ubuntu2, 0.52.1-1ubuntu1), 
libcupsppdc1:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libbinutils:amd64 
(2.30-14ubuntu2, 2.30-15ubuntu1), libebook-contacts-1.2-2:amd64 
(3.28.0-2ubuntu2, 3.28.1-1ubuntu1), gir1.2-webkit2-4.0:amd64 (2.20.0-2ubuntu1, 
2.20.1-1), vim-gtk3:amd64 (2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), 
libedata-book-1.2-25:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
virtualbox-qt:amd64 (5.2.8-dfsg-5, 5.2.8-dfsg-6), vim-tiny:amd64 
(2:8.0.1401-1ubuntu3, 2:8.0.1453-1ubuntu1), gdbserver:amd64 (8.1-0ubuntu2, 
8.1-0ubuntu3), libedata-cal-1.2-28:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
cups-bsd:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), cups-core-drivers:amd64 
(2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libunity-scopes-json-def-desktop:amd64 
(7.1.4+18.04.20180209.1-0ubuntu1, 7.1.4+18.04.20180209.1-0ubuntu2), 
cups-daemon:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), kio-extras-data:amd64 
(4:17.12.3-0ubuntu1, 4:17.12.3-0ubuntu2), language-selector-gnome:amd64 (0.186, 
0.187), libcamel-1.2-61:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
libcupsimage2:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libecal-1.2-19:amd64 
(3.28.0-2ubuntu2, 3.28.1-1ubuntu1), evolution-plugins:amd64 (3.28.0-4, 
3.28.1-1), cups:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), libcupscgi1:amd64 
(2.2.7-1ubuntu1, 2.2.7-1ubuntu2), cups-client:amd64 (2.2.7-1ubuntu1, 
2.2.7-1ubuntu2), libjavascriptcoregtk-4.0-18:amd64 (2.20.0-2ubuntu1, 2.20.1-1), 
cups-ipp-utils:amd64 (2.2.7-1ubuntu1, 2.2.7-1ubuntu2), patch:amd64 (2.7.6-1, 
2.7.6-2ubuntu1), update-notifier:amd64 (3.189, 3.190), 
libedataserver-1.2-23:amd64 (3.28.0-2ubuntu2, 3.28.1-1ubuntu1), 
zenity-common:amd64 (3.28.0-1, 3.28.1-1), gnome-getting-started-docs:amd64 
(3.28.0+git20180331-0ubuntu1, 3.28.1-0ubuntu1), libevolution:amd64 (3.28.0-4, 
3.28.1-1), evolution:amd64 (3.28.0-4, 3.28.1-1), 
gir1.2-javascriptcoregtk-4.0:amd64 (2.20.0-2ubuntu1, 2.20.1-1), 
libinput10:amd64 (1.10.3-2, 1.10.4-1), base-files:amd64 (10ubuntu1, 
10.1ubuntu1), software-properties-common:amd64 (0.96.24.26, 0.96.24.27)
  End-Date: 2018-04-11  21:48:23

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: evolution 3.28.1-1
  ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
  Uname: Linux 4.15.0-13-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu4
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Apr 12 18:17:44 2018
  ExecutablePath: /usr/bin/evolution
  InstallationDate: Installed on 2018-03-31 (12 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180331)
  ProcEnviron:
   PATH=(custom, user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/zsh
  SourcePackage: evolution
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1763546/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to