** Description changed:

- The Debian GNOME team is aiming to remove gksu before the Debian 10
- "Buster" release in 2019.
+ Debian has removed gksu. I recommend that we remove gksu and libgksu for
+ Ubuntu 18.04 LTS also.
  
- Please remove these packages to help Ubuntu follow:
+ It has recommended that developers use PolicyKit to only use elevated
+ privileges for the specific actions where it is needed.
  
- * aptoncd: Removed from Debian Testing in January 2017 (a year ago), removal 
also requested at LP: #1739800
- * macchanger-gtk: Removed from Debian Testing in January 2017 for a security 
bug
- * network-config: Removed from Debian Testing in September 2017
- 
- * edubuntu-netboot: never in Debian. Edubuntu is "on hold" since 2016.
- * sbackup: never in Debian, appears unmaintained upstream since 2014, removal 
also requested at LP: #1739800
- * umit: never in Debian, appears unmaintained upstream since at least 2014 
(maybe 2012?)
+ It is recommended that users use the gvfs admin backend available in
+ Ubuntu 17.10 and 18.04 LTS. Instead of running gksu gedit or gksu
+ nautilus to edit say /etc/default/grub, navigate to
+ admin:///etc/default/ and open the grub file.
  
  Ubuntu 17.10's default session (a themed GNOME on Wayland) does not
- support gksu.
+ support gksu. Ubuntu 18.04 switched back to using X instead of Wayland
+ as default but it is expected that Wayland will once again be the
+ default in 18.10.
  
- IMO, mythtv is the blocker for removing gksu from Ubuntu LP: #1740620
- (mythtv  does not exist in Debian)
+ $ reverse-depends src:gksu
+ Reverse-Recommends
+ ==================
+ * cinnamon                      (for gksu)
+ * lxde-core                     (for gksu)
+ * macchanger-gtk                (for gksu)
+ * wicd-gtk                      (for gksu)
+ * zenmap                        (for gksu)
+ 
+ Reverse-Depends
+ ===============
+ * edubuntu-netboot              (for gksu)
+ * peony-gksu                    (for gksu)
+ * umit                          (for gksu)
+ 
+ List of packages to remove and commentary
+ -----------------------------------------
+ * macchanger-gtk: Removed from Debian Testing in January 2017 for a security 
bug
+ * edubuntu-netboot: never in Debian. Edubuntu is "on hold" since 2016.
+ * umit: never in Debian, appears unmaintained upstream since at least 2014 
(maybe 2012?)
+ * gksu
+ * libgksu
+ 
+ Blocker bug
+ -----------
+ peony-gksu (source peony-extensions) was accepted into Ubuntu in April 2018. 
See LP: #1764201
+ 
+ References
+ ----------
+ https://jeremy.bicha.net/2018/03/21/gksu-is-dead/
+ https://bugs.debian.org/892768

** Also affects: macchanger-gtk (Ubuntu)
   Importance: Undecided
       Status: New

** Description changed:

  Debian has removed gksu. I recommend that we remove gksu and libgksu for
  Ubuntu 18.04 LTS also.
  
  It has recommended that developers use PolicyKit to only use elevated
  privileges for the specific actions where it is needed.
  
  It is recommended that users use the gvfs admin backend available in
- Ubuntu 17.10 and 18.04 LTS. Instead of running gksu gedit or gksu
- nautilus to edit say /etc/default/grub, navigate to
- admin:///etc/default/ and open the grub file.
+ Ubuntu 17.10 and 18.04 LTS. You can do this with the admin:// prefix.
+ For instance, instead of running gksu gedit or gksu nautilus to edit say
+ /etc/default/grub, navigate to admin:///etc/default/ and open the grub
+ file.
  
  Ubuntu 17.10's default session (a themed GNOME on Wayland) does not
  support gksu. Ubuntu 18.04 switched back to using X instead of Wayland
  as default but it is expected that Wayland will once again be the
  default in 18.10.
  
  $ reverse-depends src:gksu
  Reverse-Recommends
  ==================
  * cinnamon                      (for gksu)
  * lxde-core                     (for gksu)
  * macchanger-gtk                (for gksu)
  * wicd-gtk                      (for gksu)
  * zenmap                        (for gksu)
  
  Reverse-Depends
  ===============
  * edubuntu-netboot              (for gksu)
  * peony-gksu                    (for gksu)
  * umit                          (for gksu)
  
  List of packages to remove and commentary
  -----------------------------------------
  * macchanger-gtk: Removed from Debian Testing in January 2017 for a security 
bug
  * edubuntu-netboot: never in Debian. Edubuntu is "on hold" since 2016.
  * umit: never in Debian, appears unmaintained upstream since at least 2014 
(maybe 2012?)
  * gksu
  * libgksu
  
  Blocker bug
  -----------
  peony-gksu (source peony-extensions) was accepted into Ubuntu in April 2018. 
See LP: #1764201
  
  References
  ----------
  https://jeremy.bicha.net/2018/03/21/gksu-is-dead/
  https://bugs.debian.org/892768

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gksu in Ubuntu.
https://bugs.launchpad.net/bugs/1740618

Title:
  Remove gksu from Ubuntu

Status in edubuntu-netboot package in Ubuntu:
  New
Status in gksu package in Ubuntu:
  New
Status in libgksu package in Ubuntu:
  New
Status in macchanger-gtk package in Ubuntu:
  New
Status in network-config package in Ubuntu:
  Fix Released
Status in sbackup package in Ubuntu:
  Fix Released
Status in umit package in Ubuntu:
  New

Bug description:
  Debian has removed gksu. I recommend that we remove gksu and libgksu
  for Ubuntu 18.04 LTS also.

  It has recommended that developers use PolicyKit to only use elevated
  privileges for the specific actions where it is needed.

  It is recommended that users use the gvfs admin backend available in
  Ubuntu 17.10 and 18.04 LTS. You can do this with the admin:// prefix.
  For instance, instead of running gksu gedit or gksu nautilus to edit
  say /etc/default/grub, navigate to admin:///etc/default/ and open the
  grub file.

  Ubuntu 17.10's default session (a themed GNOME on Wayland) does not
  support gksu. Ubuntu 18.04 switched back to using X instead of Wayland
  as default but it is expected that Wayland will once again be the
  default in 18.10.

  $ reverse-depends src:gksu
  Reverse-Recommends
  ==================
  * cinnamon                      (for gksu)
  * lxde-core                     (for gksu)
  * macchanger-gtk                (for gksu)
  * wicd-gtk                      (for gksu)
  * zenmap                        (for gksu)

  Reverse-Depends
  ===============
  * edubuntu-netboot              (for gksu)
  * peony-gksu                    (for gksu)
  * umit                          (for gksu)

  List of packages to remove and commentary
  -----------------------------------------
  * macchanger-gtk: Removed from Debian Testing in January 2017 for a security 
bug
  * edubuntu-netboot: never in Debian. Edubuntu is "on hold" since 2016.
  * umit: never in Debian, appears unmaintained upstream since at least 2014 
(maybe 2012?)
  * gksu
  * libgksu

  Blocker bug
  -----------
  peony-gksu (source peony-extensions) was accepted into Ubuntu in April 2018. 
See LP: #1764201

  References
  ----------
  https://jeremy.bicha.net/2018/03/21/gksu-is-dead/
  https://bugs.debian.org/892768

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/edubuntu-netboot/+bug/1740618/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to