Still failing with current -proposed enabled. Let's hope it solves
itself once we fixed all other instances of triggers.

** Attachment added: "bad-180612.log"
   
https://bugs.launchpad.net/ubuntu/+source/gnome-menus/+bug/1766890/+attachment/5151671/+files/bad-180612.log

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gnome-menus in Ubuntu.
https://bugs.launchpad.net/bugs/1766890

Title:
  package gnome-menus 3.13.3-6ubuntu3.1 failed to install/upgrade:
  triggers looping, abandoned

Status in OEM Priority Project:
  Confirmed
Status in gnome-menus package in Ubuntu:
  Confirmed
Status in gnome-menus source package in Xenial:
  New

Bug description:
  Dell XPS 13 9360 (CID 201606-22338)
  pre-installed (oem) image Xenial

  [Description]

  When I tried to perform 16.04 --> 18.04 update, the update process
  failed. The process guide me to file this bug report.

  [Steps to reproduce]
  1. Update the system to the latest stack by "sudo apt-get update; sudo 
apt-get dist-upgrade -y"
  2. Reboot
  3. Make sure /etc/update-manager/release-upgrades is able to update (The 
configuration value of "Prompt" should be "lts", namely "Prompt=lts", not 
"Prompt=never").
  4. Perform the release update: "sudo apt-get update; sudo do-release-upgrade 
-d"
  5. During the update process, it prompts for "Configuring gdm3". There are 
two choices "gdm3" and "lightdm". I picked up "gdm3". Please refer to the 
attachment for the prompt details as well.

  We should use "-d" because bionic beaver has not been officially
  released yet.

  [Expected Result]

  The release update completed and I could start using Bionic instead of
  Xenial.

  [Actual Result]

  The update process failed. It shows the error message[1] and
  automatically asking for filing this bug report.

  [1]

  Preparing to unpack .../qml-module-qtquick-dialogs_5.9.5-0ubuntu1_amd64.deb 
...
  Unpacking qml-module-qtquick-dialogs:amd64 (5.9.5-0ubuntu1) over 
(5.5.1-1ubuntu1) ...
  Preparing to unpack .../qml-module-qtquick-window2_5.9.5-0ubuntu1_amd64.deb 
...
  Unpacking qml-module-qtquick-window2:amd64 (5.9.5-0ubuntu1) over 
(5.5.1-2ubuntu6) ...
  (Reading database ... 253705 files and directories currently installed.)
  Removing unity-webapps-common (2.4.17+15.10.20150616-0ubuntu2) ...
  Removing unity-webapps-service (2.5.0~+16.04.20160201-0ubuntu1) ...
  Removing webapp-container (0.23+16.04.20161028-0ubuntu2) ...
  Removing webbrowser-app (0.23+16.04.20161028-0ubuntu2) ...
  dpkg: cycle found while processing triggers:
   chain of packages whose triggers are or may be responsible:
    bamfdaemon -> gnome-menus
   packages' pending triggers which are or may be unresolvable:
    gnome-menus: /usr/share/applications
    bamfdaemon: /usr/share/applications
    libglib2.0-0:amd64: /usr/share/glib-2.0/schemas
    desktop-file-utils: /usr/share/applications
    mime-support: /usr/share/applications
  dpkg: error processing package gnome-menus (--remove):
   triggers looping, abandoned
  Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
  Processing triggers for mime-support (3.59ubuntu1) ...
  Processing triggers for libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
  Errors were encountered while processing:
   gnome-menus
  ERROR: Cannot create report: [Errno 17] File exists: 
'/var/crash/gnome-menus.0.crash'
  Exception during pm.DoInstall():  E:Sub-process /usr/bin/dpkg returned an 
error code (1)

  *** Send problem report to the developers?

  After the problem report has been sent, please fill out the form in the
  automatically opened web browser.

  What would you like to do? Your options are:
    S: Send report (376.4 KB)
    V: View report
    K: Keep report file for sending later or copying to somewhere else
    I: Cancel and ignore future crashes of this program version
    C: Cancel
  Please choose (S/V/K/I/C):

  ...... (a lot of them)

   qml-module-qtquick-controls2:amd64
   qml-module-org-kde-kconfig:amd64
   libunity-control-center1
   libqt5quickcontrols2-5:amd64
   libglib2.0-bin
   libkf5plasma5:amd64
   locales
   qml-module-qtqml-models2:amd64
   libkf5coreaddons5:amd64
   gir1.2-goa-1.0:amd64
   libwebkit2gtk-4.0-37:amd64
  Processing was halted because there were too many errors.

  Upgrade complete

  The upgrade has completed but there were errors during the upgrade
  process.

  To continue please press [ENTER]

  ubuntu@201606-22338:~$

  ==========================================================================

  ProblemType: Package
  DistroRelease: Ubuntu 18.04
  Package: gnome-menus 3.13.3-6ubuntu3.1
  ProcVersionSignature: Ubuntu 4.4.0-121.145-generic 4.4.117
  Uname: Linux 4.4.0-121-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.16
  Architecture: amd64
  Date: Wed Apr 25 22:00:01 2018
  Dependencies:

  DistributionChannelDescriptor:
   # This is a distribution channel descriptor
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-xenial-amd64-20160624-2
  ErrorMessage: triggers looping, abandoned
  InstallationDate: Installed on 2018-04-25 (0 days ago)
  InstallationMedia: Ubuntu 16.04 "Xenial" - Build amd64 LIVE Binary 
20160624-10:47
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.4
   apt  1.2.26
  SourcePackage: gnome-menus
  Title: package gnome-menus 3.13.3-6ubuntu3.1 failed to install/upgrade: 
triggers looping, abandoned
  UpgradeStatus: Upgraded to bionic on 2018-04-25 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1766890/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to