This looks good to me - please yell if not.

** Tags removed: verification-needed verification-needed-bionic
** Tags added: verification-done verification-done-bionic

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to vte2.91 in Ubuntu.
https://bugs.launchpad.net/bugs/1765389

Title:
  [FFe] Drop unrelated changes from revert-prce2.patch

Status in vte2.91 package in Ubuntu:
  Fix Released
Status in vte2.91 source package in Bionic:
  Fix Committed

Bug description:
  [Impact]

   * revert-prce2.patch includes some unrelated reverts which are
     changing the gir/vapi API in unnecessary ways compared to
     vanilla upstream. Therefore projects using this binding will
     require distro-patching to accommodate for that.
     Users of vte-2.91.vapi and Vte-2.91.gir/typelib are such candidates.
   * vte-2.91.vapi is a buildtime dependency
   * Vte-2.91.typelib is a runtime dependency with immediate effect on users.

  [Test Case]

   *
  
https://bugs.launchpad.net/ubuntu/+source/vte2.91/+bug/1765389/+attachment/5122590/+files/vte-2.91.vapi.diff
  shows the current unwanted changes of the vala bindings

  [Regression Potential]

   * This change breaks the API of vala bindings and the API/ABI of
     Vte-2.91.typelib
   * Packages using this specific API would have already received
     distro-patches which should be dropped.
   * I am currently not aware of such packages in the archive.

  [Other Info]
   
   * Test-Build: 
https://launchpad.net/~ricotz/+archive/ubuntu/staging/+sourcepub/8991295/+listing-archive-extra

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/vte2.91/+bug/1765389/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to