On Ubuntu 18.04 the problem is solved if you installed the available package by 
clicking the link below
Here is the origin of the .deb

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to ibus in Ubuntu.

  Ubuntu 18.04's ibus package breaks password fields in Firefox (by
  lowering & raising window whenever they're focused)

Status in ibus package in Ubuntu:

Bug description:
  tl;dr: starting in Ubuntu 18.04, "ibus" seems to lower and raise
  Firefox, whenever the user tries to focus an <input type="password">
  field on a web page.  This is not a regression in Firefox, as the same
  Firefox version runs just fine in Ubuntu 17.10 -- it seems to be a bug
  in ibus, because it only happens (in 18.04) when the environmental
  variable GTK_IM_MODULE is at its default value (which is "ibus").  It
  had this same value in 17.10 but the bug didn't happen there; hence,
  I'm guessing there was a change in ibus (or a related package) that
  caused this breakage / lowering+raising.

  This is pretty bad, because in some cases, the focus-loss can mean users are 
simply unable to fill in password fields that previously were working fine. 
(see "ACTUAL RESULTS" below)
  STEPS TO REPRODUCE #1, via "BitWarden" Firefox extension:
   1. Start Firefox. (fresh profile if you like)
   2. Install BitWarden from 
   3. Click the BitWarden toolbar icon to spawn a menu-pane.
   4. Click "Log in" at the bottom of that pane.
   5. Click the "Master Password" field.

   The menu pane disappears as soon as the Master Password field receives focus.
   I should be able to type in a password; pane shouldn't disappear.

  STEPS TO REPRODUCE #2, via Reddit:
   1. Visit https://www.reddit.com/r/firefox/ (or any reddit page)
   2. Click "Log in or sign up in seconds" at the extreme upper right of the 
        (click the "Log in" part of that sentence)
   3. Try to click the password field (or "tab" into it) and type in some text.

   Try as you might, the password field never receives focus.
   Password field should accept focus & let me type text into it.

  If I run firefox from the command line with env var GTK_IM_MODULE="",
  then I get "expected results".  But with the default value of that env
  var, I get "actual results" (broken behavior, unable to enter

  I initially reported this in Firefox, here:
  https://bugzilla.mozilla.org/show_bug.cgi?id=1451466 (with a few
  dependent bugs for the usage-specific STR quoted above).  But I think
  it's a bug in ibus, hence filing here now.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: ibus 1.5.17-3ubuntu3
  ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
  Uname: Linux 4.15.0-15-generic x86_64
  ApportVersion: 2.20.9-0ubuntu5
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Apr 18 23:22:05 2018
  InstallationDate: Installed on 2018-04-17 (1 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180416)
  SourcePackage: ibus
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to