s/addition/change/

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to vte2.91 in Ubuntu.
https://bugs.launchpad.net/bugs/1780501

Title:
  Traceback calling Vte.Terminal.feed_child()

Status in ubuntu-release-upgrader package in Ubuntu:
  Triaged
Status in vte2.91 package in Ubuntu:
  Won't Fix
Status in ubuntu-release-upgrader source package in Bionic:
  Invalid
Status in vte2.91 source package in Bionic:
  Won't Fix

Bug description:
  I was upgrading from Bionic to Cosmic when I received a conffile
  prompt regarding /etc/update-initramfs/initramfs.conf, I clicked keep
  and then saw this Traceback:

  Original exception was:
  Traceback (most recent call last):
    File "/tmp/ubuntu-release-upgrader-filpk342/cosmic", line 8, in <module>
      sys.exit(main())
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeMain.py", line 
238, in main
      if app.run():
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeController.py", 
line 1949, in run
      return self.fullUpgrade()
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeController.py", 
line 1912, in fullUpgrade
      if not self.doDistUpgrade():
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeController.py", 
line 1248, in doDistUpgrade
      res = self.cache.commit(fprogress,iprogress)
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeCache.py", line 
293, in commit
      apt.Cache.commit(self, fprogress, iprogress)
    File "/usr/lib/python3/dist-packages/apt/cache.py", line 606, in commit
      pm = apt_pkg.PackageManager(self._depcache)
    File "/usr/lib/python3/dist-packages/apt/cache.py", line 569, in 
install_archives
      # compat with older API
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeView.py", line 
229, in run
      res = os.WEXITSTATUS(self.wait_child())
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeViewGtk3.py", 
line 340, in wait_child
      self.update_interface()
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeViewGtk3.py", 
line 347, in update_interface
      InstallProgress.update_interface(self)
    File "/usr/lib/python3/dist-packages/apt/progress/base.py", line 252, in 
update_interface
      if err.errno != errno.EAGAIN and err.errno != errno.EWOULDBLOCK:
    File 
"/tmp/ubuntu-release-upgrader-filpk342/DistUpgrade/DistUpgradeViewGtk3.py", 
line 276, in conffile
      self.term.feed_child("n\n", -1)
  TypeError: Vte.Terminal.feed_child() takes exactly 2 arguments (3 given)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1780501/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to