Is the step to delete old metadata actually required? That will complicate
the SRU if so..

On Wed, Jul 11, 2018, 13:25 François Marier <franc...@debian.org> wrote:

> >From https://bugs.launchpad.net/ubuntu/+source/appstream-
> glib/+bug/1780520/comments/2:
>
> "I have uploaded a fixed package to my PPA:
>
> https://launchpad.net/~fmarier/+archive/ubuntu/ppa?field.series_filter=xenial
>
> Here's how I fixed the problem:
>
> 1. upgrade the appstream-glib package to the one in my PPA
> 2. delete /var/cache/app-info/xmls/fwupd.xml
> 3. run `fwupdmgr refresh` as root to re-download the XML file"
>
> This is the patch I added to the package:
> https://bugs.launchpad.net/ubuntu/+source/appstream-
>
> glib/+bug/1780520/+attachment/5161135/+files/06_ampersand_in_attribute_values.patch
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1780442
>
> Title:
>   Please backport fix for & in attributes
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/fwupd/+bug/1780442/+subscriptions
>

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to appstream-glib in Ubuntu.
https://bugs.launchpad.net/bugs/1780442

Title:
  Please backport fix for & in attributes

Status in Fwupd:
  New
Status in appstream-glib package in Ubuntu:
  Fix Released
Status in appstream-glib source package in Xenial:
  Confirmed

Bug description:
  [Impact]

  There are instances of fwupd being unable to run updates on certain
  devices on Ubuntu 16.04. due to a "&" in metadata.

  [Test Case]

   * Try to perform an update on a 8bitdo affected device.

  [Regression Potential]

   * Regressions would occur in metadata processing where the fwupd
  daemon wouldn't be able to process it.

  [Other Info]
   
  This was discussed here:
  https://github.com/hughsie/fwupd/issues/565#issuecomment-402534337

  This has been fixed in appstream-glib to prevent & in the metadata.  This fix 
is already in 18.04 and just needs to be backported to 16.04.
  
https://github.com/hughsie/appstream-glib/commit/6048520484101df5d33f3c852c10640e630d20cf

To manage notifications about this bug go to:
https://bugs.launchpad.net/fwupd/+bug/1780442/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to