I have the same problem and my board is MSI X370 Pro Carbon, (same
ALC1220 Chipset). Tried Kubuntu 18.04 and Ubuntu 18.04. Recording with
audacity also slow to the extreme. I changed sample rate in audacity to
510000 or 520000 Hz as a temporary workaround, but the sound is very

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to alsa-driver in Ubuntu.

  [Realtek ALC1220 ASUS PRIME X370] Recording is very slow and plays 10x

Status in alsa-driver package in Ubuntu:

Bug description:
  Recording applications (audacity, arecord, gnome-sound-recorder)
  record extremely slowly (at what seems to be 0,1x speed), which means
  that at playback the sound is played at a very high pitch and much
  faster than the original.

  To help you understand the issue, I've attached an archive containing two 
files recorded at the same time, one with arecord -f cd and the other with a 
stand-alone Olympus recorder.
  A video of Audacity's behavior when trying to record is also available: 
  Look at the seconds hand of the xclock and how much it is moving before 
Audacity is done recording one second of audio.

  Things I've already tried:
  *  Purging and reinstalling Audacity
  *  Purging and reinstalling Pulseaudio following the guide on the Ubuntu Wiki
  *  Running audacity with this command: Exec=env PULSE_LATENCY_MSEC=30 
audacity as suggested on AskUbuntu
  *  Reinstalling Ubuntu on a new hard disk
  *  Running audacity on a live CD (in Ubuntu version 16.04.3, 17.10.1, 18.04 
daily and Xubuntu 17.10.1, 18.04)

  The machine is a Ryzen 5 1600 with an ASUS X370 Prime motherboard.

  The problem can be reproduced as follows:

  * Boot a live DVD of Ubuntu/Xubuntu 16.04.3, 17.10.1, 18.04 (versions I've 
tested with)
  * Install audacity via the terminal
  * Start recording, microphone is connected to the rear microphone jack.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 4.13.0-38.43~16.04.1-generic 4.13.16
  Uname: Linux 4.13.0-38-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.16
  Architecture: amd64
   /dev/snd/controlC1:  jacopo     2417 F.... pulseaudio
   /dev/snd/controlC0:  jacopo     2417 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Wed Apr 18 09:35:50 2018
  InstallationDate: Installed on 2018-03-03 (45 days ago)
  InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaRecordingTest: ALSA recording test through plughw:Generic failed
  Symptom_Card: HD-Audio Generic - HD-Audio Generic
  Symptom_Jack: Pink Mic, Rear
  Symptom_Type: None of the above
  Title: [System Product Name, Realtek ALC1220, Pink Mic, Rear] Recording 
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/06/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3805
  dmi.board.asset.tag: Default string
  dmi.board.name: PRIME X370-PRO
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to