There are no report from 3.28 or newer, seems to be resolved

** Changed in: gnome-calculator (Ubuntu)
       Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gnome-calculator in Ubuntu.
https://bugs.launchpad.net/bugs/1745188

Title:
  gnome-calculator crashed with SIGABRT in mpfr_assert_fail → mpfr_init2
  → mpc_init3 → mpc_pow_usi_naive → mpc_pow_usi

Status in gnome-calculator package in Ubuntu:
  Fix Released
Status in mpclib3 package in Ubuntu:
  Triaged

Bug description:
  I cannot launch gnome-calculator because of the following:

  ```
  ../../src/init2.c:52: MPFR assertion failed: p >= 2 && p <= 
((mpfr_prec_t)((mpfr_uprec_t)(~(mpfr_uprec_t)0)>>1))
  Aborted (core dumped)
  ```

  errors.u.c:
  https://errors.ubuntu.com/problem/40a6712b7f663d518c85d34a30891ff7629f9041

  
  ProblemType: Crash
  DistroRelease: Ubuntu 18.04
  Package: gnome-calculator 1:3.26.0-0ubuntu1
  ProcVersionSignature: Ubuntu 4.14.0-13.15-generic 4.14.7
  Uname: Linux 4.14.0-13-generic x86_64
  ApportVersion: 2.20.8-0ubuntu6
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Wed Jan 24 19:13:49 2018
  ExecutablePath: /usr/bin/gnome-calculator
  InstallationDate: Installed on 2017-08-21 (156 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170820)
  ProcCmdline: gnome-calculator
  Signal: 6
  SourcePackage: gnome-calculator
  StacktraceTop:
   mpfr_assert_fail () at /usr/lib/x86_64-linux-gnu/libmpfr.so.4
   mpfr_init2 () at /usr/lib/x86_64-linux-gnu/libmpfr.so.4
   () at /usr/lib/x86_64-linux-gnu/libmpc.so.3
   mpc_pow_usi () at /usr/lib/x86_64-linux-gnu/libmpc.so.3
   number_xpowy_integer () at 
/usr/lib/x86_64-linux-gnu/gnome-calculator/libcalculator.so
  Title: gnome-calculator crashed with SIGABRT in mpfr_assert_fail()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-calculator/+bug/1745188/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to