@gunnarhj I tested the ppa and bionic-propsed a machine with fresh clean
install of bionic with CanoScan LIDE 100. The issue is *not* fixed on
this machine.

Here are the details of my testing:

I switched back and forth between distro-default, ppa and bionic-
proposed versions of libsane-common (and libsane1), restarted the
machine etc.


After adding ppa, I run apt upgrade which updated these libsane-common,
libsane1, sane-utils packages to

libsane-common/bionic,bionic,now 1.0.27-1~experimental3ubuntu2.2~ppa all 
libsane1/bionic,now 1.0.27-1~experimental3ubuntu2.2~ppa amd64 
sane-utils/bionic,now 1.0.27-1~experimental3ubuntu2.2~ppa amd64 


I did a test scan. Colored bar still appeared. I restarted the system
(or should I have restarted some sane service?). Tried scanning again.
Issue still exists.

To go back to distro default, I removed the ppa and libsane-common. This
removed a whole bunch of dependencies including ubuntu-desktop and
simple-scan. Reinstalling ubuntu-desktop brought libsane-common etc
back. Scanned a page again to see if there are any surprises. None. The
problem still existed.


I enabled bionic-proposed channel repo. It showed a whole bunch of
updates. I had to pin the packages and install libsane-common/bionic-
proposed and sane-utils/bionic-proposed.

package versions after this:
1.0.27-1~experimental3ubuntu2.2 all [installed]
libsane1/bionic-proposed,now 1.0.27-1~experimental3ubuntu2.2 amd64 [installed]
sane-utils/bionic-proposed,now 1.0.27-1~experimental3ubuntu2.2 amd64 [installed]

The problem persisted during immediate scan and after a restart.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to sane-backends in Ubuntu.

  genesys_gl847 scanners produce a black band in scanned images on
  Ubuntu 17.10+,  18.04 LTS and 18.10 Cosmic cuttlefish

Status in sane-backends:
Status in sane-backends package in Ubuntu:
  Fix Released
Status in sane-backends source package in Bionic:
  Fix Committed
Status in sane-backends source package in Disco:
  Fix Committed
Status in sane-backends package in Debian:

Bug description:

  When using a Genesys GL847 scanner, the documents get disfigured by a
  discolored bar. The proposed uploads should fix the issue. They are
  available in this PPA:


  [Test case]

  1. Install the libsane (libsane1 in bionic), libsane-common
     and sane-utils packages from {bionic,disco]-proposed.

  2. Use an affected device to scan, and find that the issue is
     no longer present.

  [Regression risk]

  Upstream commit, focused bug fix => low regression risk

  [Original description]

  On Windows it works but on my Ubuntu 17.10, 18.04 and 18.10 I see a
  black band on scanned image. The scanner is Canon CanoScan LIDE100.
  Libsane version is 1.0.27-1~experimental2ubuntu1

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to