As a new chromium version came in I have tested this again:

gert@flupp:~$ rm -rf ~/snap/chromium/current/.config/
gert@flupp:~$ chromium
[10090:10090:1109/162748.523398:ERROR:sandbox_linux.cc(369)] 
InitializeSandbox() called with multiple threads in process gpu-process.
[10090:10090:1109/162748.862772:ERROR:buffer_manager.cc(488)] 
[.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error 
from previous GL command
[10155:1:1109/162749.902762:ERROR:child_process_sandbox_support_impl_linux.cc(81)]
 FontService unique font name matching request did not receive a response.
[10155:1:1109/162749.903262:ERROR:child_process_sandbox_support_impl_linux.cc(81)]
 FontService unique font name matching request did not receive a response.
gert@flupp:~$ 

Again the config was not transfered.

gert@flupp:~$ sed -e 's/.*"last_chrome_version":"\([0-9\.]\+\)".*/\1\n/' 
~/.config/chromium/Default/Preferences
sed: can't read /home/gert/.config/chromium/Default/Preferences: No such file 
or directory

Should there be a Link "Default" to the "Profile 1" directory?

Here is the content of my former .config/chromium directory:

gert@flupp:~$ ls -l ~/.config/chromium/
total 4232
drwx------  2 gert gert    4096 Aug 22  2015  Avatars
-rw-------  1 gert gert 4194304 Okt 24 11:13  BrowserMetrics-spare.pma
drwx------  4 gert gert    4096 Okt 24 11:17  CertificateRevocation
drwx------  3 gert gert    4096 Aug  2 23:09  CertificateTransparency
-rw-------  1 gert gert      22 Jun 18  2016  Channels
-rw-rw----  1 gert gert       4 Okt 24 13:47  chrome_shutdown_ms.txt
drwx------  2 gert gert    4096 Jan 31  2014 'Crash Reports'
drwx------  2 gert gert    4096 Feb  8  2018  Dictionaries
drwx------  3 gert gert    4096 Sep  3  2015  EVWhitelist
drwx------  3 gert gert    4096 Mai 19 12:46  FileTypePolicies
-rw-rw----  1 gert gert       0 Jun  3  2010 'First Run'
drwx------  3 gert gert    4096 Sep 13  2018  InterventionPolicyDatabase
-rw-------  1 gert gert   23284 Okt 24 13:47 'Local State'
drwx------  2 gert gert    4096 Aug  5 18:41  MEIPreload
drwx------  2 gert gert    4096 Sep 10  2016  OriginTrials
drwx------  2 gert gert    4096 Feb 23  2012  PepperFlash
drwx------  4 gert gert    4096 Nov 12  2014  pnacl
drwx------ 32 gert gert    4096 Okt 24 13:47 'Profile 1'
drwx------  2 gert gert    4096 Okt 24 13:44 'Safe Browsing'
-rw-r-----  1 gert gert    5120 Okt 31  2017 'Safe Browsing Channel IDs'
-rw-r-----  1 gert gert       0 Okt 31  2017 'Safe Browsing Channel IDs-journal'
-rw-r-----  1 gert gert    9216 Okt 12 19:05 'Safe Browsing Cookies'
-rw-r-----  1 gert gert       0 Okt 12 19:05 'Safe Browsing Cookies-journal'
-rw-------  1 gert gert      50 Dez 16  2011 'Service State'
drwx------  3 gert gert    4096 Dez 23  2015  ShaderCache
drwx------  3 gert gert    4096 Dez 22  2018  SSLErrorAssistant
drwx------  4 gert gert    4096 Mai 13  2018 'Subresource Filter'
drwx------  2 gert gert    4096 Feb  1  2013  Temp
drwx------  2 gert gert    4096 Jan 18  2018 'Webstore Downloads'
drwx------  2 gert gert    4096 Okt 14  2016  WidevineCdm

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to chromium-browser in Ubuntu.
https://bugs.launchpad.net/bugs/1849693

Title:
  [snap] Upgrading from kubuntu 19.04 to 19.10 lost all chromium
  settings

Status in chromium-browser package in Ubuntu:
  Incomplete

Bug description:
  I just have upgraded from kubuntu 19.04 to 19.10. chromium was changed
  from deb to snap 77.0.3865.120-0ubuntu1~snap1. When starting the
  browser for the first time, it should have imported all former
  settings. But it did not. E.g. all bookmarks and saved passwords are
  gone.

  Is there a way to start the config import afterwards?

  The workaround mentioned under the following link did not help in my case:
  https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1849160
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CurrentDesktop: KDE
  DRM.card0-DP-1:
   enabled: disabled
   dpms: Off
   status: disconnected
   edid-base64: 
   modes:
  DRM.card0-DP-2:
   enabled: disabled
   dpms: Off
   status: disconnected
   edid-base64: 
   modes:
  DRM.card0-DP-3:
   enabled: disabled
   dpms: Off
   status: disconnected
   edid-base64: 
   modes:
  DRM.card0-HDMI-A-1:
   enabled: enabled
   dpms: On
   status: connected
   edid-base64: 
AP///////wAVw4UjAQEBAQIXAQOANCF46vkVo1RQnicSUFShCACpQIGAgUCzAIHAAQEBAQEBKDyAoHCwI0AwIDYAB0QhAAAaAAAA/wA0NTE3NDAxMwogICAgAAAA/QA7PR9MEQAKICAgICAgAAAA/ABFVjI0MzZXCiAgICAgALk=
   modes: 1920x1200 1600x1200 1680x1050 1280x1024 1280x960 1280x720 1024x768 
800x600 640x480 720x400
  DRM.card0-HDMI-A-2:
   enabled: disabled
   dpms: Off
   status: disconnected
   edid-base64: 
   modes:
  DRM.card0-HDMI-A-3:
   enabled: disabled
   dpms: Off
   status: disconnected
   edid-base64: 
   modes:
  DRM.card0-VGA-1:
   enabled: disabled
   dpms: Off
   status: disconnected
   edid-base64: 
   modes:
  DiskUsage:
   Filesystem     Type   Size  Used Avail Use% Mounted on
   /dev/sda5      ext4   394G   48G  327G  13% /home
   tmpfs          tmpfs  3,9G   19M  3,9G   1% /dev/shm
   /dev/sda5      ext4   394G   48G  327G  13% /home
  DistroRelease: Ubuntu 19.10
  InstallationDate: Installed on 2018-11-24 (334 days ago)
  InstallationMedia: Kubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 
(20181017.2)
  MachineType: Gigabyte Technology Co., Ltd. Z68X-UD3H-B3
  Package: chromium-browser 77.0.3865.120-0ubuntu1~snap1
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-19-generic 
root=UUID=c2336ec0-2c4e-4cf0-a475-ea8727cc3ac8 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
  Snap.ChromeDriverVersion: ChromeDriver 78.0.3904.70 
(edb9c9f3de0247fd912a77b7f6cae7447f6d3ad5-refs/branch-heads/3904@{#800})
  Snap.ChromiumVersion: Chromium 78.0.3904.70 snap
  Tags:  eoan snap
  Uname: Linux 5.3.0-19-generic x86_64
  UpgradeStatus: Upgraded to eoan on 2019-10-24 (0 days ago)
  UserGroups: adm audio cdrom dip lpadmin plugdev sambashare sudo vboxusers 
video
  _MarkForUpload: True
  dmi.bios.date: 05/02/2011
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F2
  dmi.board.name: Z68X-UD3H-B3
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd05/02/2011:svnGigabyteTechnologyCo.,Ltd.:pnZ68X-UD3H-B3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnZ68X-UD3H-B3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: Z68X-UD3H-B3
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1849693/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to