1. Screenshot attached.  I have been using two screens but to simplify
things I have confirmed that only having one makes no difference, so I
am sticking to that whilst testing.

2. I did already have show seconds set, I have now tried without and it
doesn't seem to make a difference

3. I thought I had disabled all extensions, though I am not entirely
sure of the official method of doing that.  If I go to
https://extensions.gnome.org/local/ I see only Desktop Icons, Ubuntu App
Indicators and Ubuntu Dock and they are all disabled, but as you can see
from the screenshot I don't see exactly the same as I see if I logon
using Gnome.  For instance the Dock is not autohiding.  So I don't know
what is going on there.  Logging on using Gnome does not stop the leak
though.

I see I have a larger selection of logon options than I see in a clean
install, I have Gnome, Gnome Classic, Gnome on Xorg, Ubuntu, Ubuntu on
Wayland, and Unity.  I tried them all a few days ago and they all
exhibited the leak except Gnome Classic and Unity, though I have done a
lot of cleaning up trying to fix the problem since then so if it would
be useful I can repeat that test.


** Attachment added: "Desktop screenshot"
   
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1862910/+attachment/5327658/+files/Screenshot%20from%202020-02-12%2014-02-37.png

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gnome-shell in Ubuntu.
https://bugs.launchpad.net/bugs/1862910

Title:
  gnome-shell leaking memory

Status in gnome-shell package in Ubuntu:
  Incomplete

Bug description:
  On one of my machines which has been upgraded over several years and
  is now running 19.10 just one of the configured users appears to be
  seeing a dramatic memory leak in gnome-shell, even when nothing is
  happening on the UI. Immediately after logging on, using the Ubuntu
  selection from the logon screen, gnome shell shows as using about
  134MB. From there it climbs at about 300MB per hour and after a few
  hours the machine grinds to a crawl, not surprisingly. This happens
  even if the user logs on and then the machine is left completely
  alone. Logout and back in frees all the memory.
  A test user I have configured sees no such problem.
  I have uninstalled all extensions apart from the system ones, disabled
  all the system ones and reset all the gnome settings using dconf reset
  -f /org/gnome/ to no avail. Also I have removed
  ~/.local/share/gnome-shell and allowed it to recreate it.
  Also I have removed .compiz, .config/dconf/user, .gconf, .gnome, .gnome2.
  I can't see anything obvious in the log.
  It must be something in my settings that is triggering it as the other
  user does not see it, but I have run out of ideas on what to try.

  See also bug #1856516

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: gnome-shell 3.34.1+git20191024-1ubuntu1~19.10.1
  ProcVersionSignature: Ubuntu 5.3.0-29.31-generic 5.3.13
  Uname: Linux 5.3.0-29-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8.2
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Feb 12 08:54:21 2020
  DisplayManager: gdm3
  InstallationDate: Installed on 2014-10-21 (1939 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20141017)
  RelatedPackageVersions: mutter-common 3.34.1+git20191107-1ubuntu1~19.10.1
  SourcePackage: gnome-shell
  UpgradeStatus: Upgraded to eoan on 2020-01-27 (15 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1862910/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to