I was able to solve the problem, by switching GPU-driver.
"Software & Updates" -> "Additional Drivers" - I switched from:
"Using X.Org X server - Nouveau display driver" to the NVIDIA-435.

Perhaps this is only specific to my setup, by powering monitors from GPU
as well as motherboard. Hope it helps someone.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to mutter in Ubuntu.

  Dual monitor not working in 18.04(.1) on a dual-radeon-GPU system

Status in mutter package in Ubuntu:

Bug description:
  Dual monitor setup works fine in 16.04 LTS. Not anymore in 18.04(.1).
  This renders 18.04 useless. Till this is solved will have to stick
  with 16.04. i.e. this is a pretty critical bug!

  After a fresh install from DVD first got a freeze on login screen (live CD 
will run ubuntu though!). This could be solved by switching to lightdm display 
manager. (Boo! for GDM that cannot even show a login screen without freezing 
the system)

  But one issue remains: the dual monitor setup will not work in 18.04.

  I can see the mouse move to the second monitor. I can drag windows
  there (and lose sight of them). I can see the mouse cursor change to
  click a link. But otherwise there is a completely black screen, or
  dots / colored fields, but nothing even resembling a program.

  MB: Gigabyte GA-A75M-UD2H
  Monitor that works fine: ASUS on Radeon HD 6550D
  monitor that only shows mouse cursor: benq on Radeon HD 4870 (onboard on the 
gigabyte motherboard)

  Note: dual monitor setup did not work with other upgrades after 16.04. I 
hoped this would be solved with the next LTS update. Not so, to great 
  Ubuntu really fails if with new major updates it makes systems fall down. 
This kind of thing should work FLAWLESS out of the box! How would anyone move 
to Ubuntu when this kind of thing does not work? Windows is a drama, but at 
least it has the mere basics working!

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3.1
  ProcVersionSignature: Ubuntu 4.4.0-135.161-generic 4.4.140
  Uname: Linux 4.4.0-135-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.18
  Architecture: amd64
  CompizPlugins: No value set for 
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Sun Sep 16 23:09:31 2018
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
   virtualbox, 5.0.40, 4.4.0-133-generic, x86_64: installed
   virtualbox, 5.0.40, 4.4.0-134-generic, x86_64: installed
   virtualbox, 5.0.40, 4.4.0-135-generic, x86_64: installed
   Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6550D] 
[1002:9640] (prog-if 00 [VGA controller])
     Subsystem: Gigabyte Technology Co., Ltd BeaverCreek [Radeon HD 6550D] 
   Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4870] [1002:9440] 
(prog-if 00 [VGA controller])
     Subsystem: PC Partner Limited / Sapphire Technology RV770 [Radeon HD 4870] 
  InstallationDate: Installed on 2016-10-02 (714 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
  MachineType: Gigabyte Technology Co., Ltd. GA-A75M-UD2H
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-135-generic 
root=UUID=a5b3b47d-aa17-4b49-ba9a-eeaefc2556d6 ro quiet splash
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/17/2011
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F6c
  dmi.board.name: GA-A75M-UD2H
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.product.name: GA-A75M-UD2H
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.91-2~16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~16.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.8
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
  xserver.bootTime: Sun Sep 16 19:34:47 2018
  xserver.configfile: default
  xserver.errors: RADEON(G0): [XvMC] Failed to initialize extension.
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.18.4-0ubuntu0.8
  xserver.video_driver: radeon

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to