If the heat problem still persists then next please run 'top' to confirm
which process is using the most CPU.

Also, please run this again:

  journalctl -b0 > journal.txt

because the attachment in comment #4 looks like Xorg failed to start.

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg-server in Ubuntu.
https://bugs.launchpad.net/bugs/1879484

Title:
  Lenovo X1 Extreme with thunderbolt docking station causes overheat
  with concert of fans

Status in xorg-server package in Ubuntu:
  Incomplete

Bug description:
  Hey everyone,
  after resolving some of the problems I got after upgrading to 20.04 [1] I'm 
now using my Lenovo X1 Extreme Gen 2 with the thunderbolt docking station (and 
an HDMI monitor attached).
  Everything worked out of the box, except for the increased general heat of 
the system (constantly over 70 °C) and the consequent concert of fans that 
makes working aside the (closed) laptop almost impossible.
  It is really hard to understand if there's a specific process causing the CPU 
to be so constantly stressed, and what is more curious is that monitoring the 
general status of the system resources (CPU, Memory and so on) there are no 
peaks, it shows a normal usage, which is what I do: browser, mail, and some 
console. Something I would expect that with 16 cpu and 32 gigs of RAM should 
not be a concern.

  Both thermald and tlp services are obviously installed and running.

  [1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1876741

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.6.0-1008.8-oem 5.6.4
  Uname: Linux 5.6.0-1008-oem x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/0000:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  BootLog:
   
  CasperMD5CheckResult: skip
  CompositorRunning: None
  Date: Tue May 19 12:41:24 2020
  DistUpgraded: 2020-04-28 11:09:59,157 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: focal
  DistroVariant: ubuntu
  DkmsStatus:
   backport-iwlwifi, 8324, 5.4.0-31-generic, x86_64: installed
   nvidia, 440.64, 5.4.0-31-generic, x86_64: installed
   nvidia, 440.64, 5.6.0-1008-oem, x86_64: installed (WARNING! Diff between 
built and installed module!) (WARNING! Diff between built and installed 
module!) (WARNING! Diff between built and installed module!)
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (rev 02) (prog-if 00 
[VGA controller])
     Subsystem: Lenovo UHD Graphics 630 (Mobile) [17aa:229f]
   NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] [10de:1f91] (rev 
a1) (prog-if 00 [VGA controller])
     Subsystem: Lenovo TU117M [GeForce GTX 1650 Mobile / Max-Q] [17aa:229f]
  InstallationDate: Installed on 2019-12-10 (161 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  MachineType: LENOVO 20QVCTO1WW
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.6.0-1008-oem 
root=UUID=c61df9cc-bd36-4ed2-8f52-de114bbf3fc3 ro rd.driver.blacklist=nouveau 
modprobe.blacklist=nouveau
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: Upgraded to focal on 2020-04-28 (21 days ago)
  dmi.bios.date: 01/20/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N2OET42W (1.29 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QVCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0T08861 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN2OET42W(1.29):bd01/20/2020:svnLENOVO:pn20QVCTO1WW:pvrThinkPadX1Extreme2nd:rvnLENOVO:rn20QVCTO1WW:rvrSDK0T08861WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad X1 Extreme 2nd
  dmi.product.name: 20QVCTO1WW
  dmi.product.sku: LENOVO_MT_20QV_BU_Think_FM_ThinkPad X1 Extreme 2nd
  dmi.product.version: ThinkPad X1 Extreme 2nd
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1879484/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to