The branch main has been updated by kib:

URL: 
https://cgit.FreeBSD.org/src/commit/?id=1b36b3869f3be722dd15760ddcb4598b6dfe7cf7

commit 1b36b3869f3be722dd15760ddcb4598b6dfe7cf7
Author:     Konstantin Belousov <[email protected]>
AuthorDate: 2021-04-06 03:30:09 +0000
Commit:     Konstantin Belousov <[email protected]>
CommitDate: 2021-07-12 09:34:37 +0000

    mlx5en: eliminate magic constant
    
    Use sizeof(struct udphdr) where appropriate
    
    Reviewed by:    hselasky
    Sponsored by:   Mellanox Technologies/NVidia Networking
    MFC after:      1 week
---
 sys/dev/mlx5/mlx5_en/mlx5_en_tx.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/sys/dev/mlx5/mlx5_en/mlx5_en_tx.c 
b/sys/dev/mlx5/mlx5_en/mlx5_en_tx.c
index 124d2afe414c..1ba47e44ae96 100644
--- a/sys/dev/mlx5/mlx5_en/mlx5_en_tx.c
+++ b/sys/dev/mlx5/mlx5_en/mlx5_en_tx.c
@@ -277,7 +277,7 @@ mlx5e_get_full_header_size(const struct mbuf *mb, const 
struct tcphdr **ppth)
                        goto tcp_packet;
                case IPPROTO_UDP:
                        ip_hlen = ip->ip_hl << 2;
-                       eth_hdr_len += ip_hlen + 8;
+                       eth_hdr_len += ip_hlen + sizeof(struct udphdr);
                        th = NULL;
                        goto udp_packet;
                default:
@@ -293,7 +293,7 @@ mlx5e_get_full_header_size(const struct mbuf *mb, const 
struct tcphdr **ppth)
                        eth_hdr_len += sizeof(*ip6);
                        goto tcp_packet;
                case IPPROTO_UDP:
-                       eth_hdr_len += sizeof(*ip6) + 8;
+                       eth_hdr_len += sizeof(*ip6) + sizeof(struct udphdr);
                        th = NULL;
                        goto udp_packet;
                default:
_______________________________________________
[email protected] mailing list
https://lists.freebsd.org/mailman/listinfo/dev-commits-src-all
To unsubscribe, send any mail to "[email protected]"

Reply via email to