Hi again,

So I did made the changes and set the following

always_populate_raw_post_data 1
Then I started the Artikel Export von Comarch ERP and still my ERP looks
like this.

2016-07-15 16:07:54
REQUEST:

RESPONSE:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/";
xmlns:ns1="OXERPService"><SOAP-ENV:Body><ns1:OXERPLoginResponse><ns1:OXERPLoginResult><ns1:blResult>true</ns1:blResult><ns1:sMessage>18abba6119ac15946606f1837284987d</ns1:sMessage></ns1:OXERPLoginResult></ns1:OXERPLoginResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>








*Mit freundlichen Grüßen | **Warm Regards**,*

Mirza Ahtasham Ahmad
M +4917645387460 | Skype: ahtasham82





On Fri, Jul 15, 2016 at 12:32 PM, Mirza Ahtasham Ahmad <ahtasha...@gmail.com
> wrote:

> Hi,
>
> First of all thanks for the exemption. Secondly, I have asked my PM for
> the info where and whom he contacted. He is not inhouse today so waiting
> for the E-Mail response.
>
> Then, thanks for your pointing out and now I can see where the problem
> could be, I just checked HTTP_RAW_POST_DATA is deprecated in PHP 5,6 and by
> default on the server is always_populate_raw_post_data set to -1 which
> surpresses RAW POST DATA. That must be the reason why the REQUEST is not
> being logged in erp.log
>
> I am going to change the Server Setting of always_populate_raw_post_data
> to 1 and let the export von ERP trigger again to see the outcome.
>
> Thanks to all,
>
>
>
>
>
>
> *Mit freundlichen Grüßen | **Warm Regards**,*
>
> Mirza Ahtasham Ahmad
> M +4917645387460 | Skype: ahtasham82
>
>
>
>
>
> On Fri, Jul 15, 2016 at 11:59 AM, Reinhard Vogl <
> reinhard.v...@deutschedaten.de> wrote:
>
>> Hi Keywan,
>>
>>
>>
>> as I remember right, older ErpLogger versions fetches the Request from a
>> global var:
>>
>> $GLOBALS['HTTP_RAW_POST_DATA'];
>>
>>
>>
>> So dependent on you webserver and PHP version it is not given, that the
>> variable is filled.
>>
>> (http://php.net/manual/de/ini.core.php#ini.always-populate-raw-post-data)
>>
>>
>>
>> If you have a possibility to manual fill that variable before SOAP
>> handling you will get your Request logged.
>>
>> Other possible variables you can use for seeing your request are:
>>
>> if($HTTP_RAW_POST_DATA)
>>
>>         $GLOBALS['HTTP_RAW_POST_DATA'] = $HTTP_RAW_POST_DATA;
>>
>>
>>
>> $f = file("php://input");
>>
>> $GLOBALS['HTTP_RAW_POST_DATA'] =  implode(" ", $f);
>>
>>
>>
>> Best regards,
>>
>> Reini
>>
>>
>>
>>
>>
>> *Von:* dev-general-boun...@lists.oxidforge.org [mailto:
>> dev-general-boun...@lists.oxidforge.org] *Im Auftrag von *Mirza Ahtasham
>> Ahmad
>> *Gesendet:* Freitag, 15. Juli 2016 11:39
>>
>> *An:* dev-general@lists.oxidforge.org
>> *Betreff:* Re: [oxid-dev-general] ERP Module Issues
>>
>>
>>
>> Hi Keywan,
>>
>>
>>
>> Thanks for your reply. Getting the source code will surely help me
>> finding the problem myself. I will get into it so that I can get the code.
>> Thanks.
>>
>>
>>
>> Then the code explaination you did. The problem is that the ERP is
>> sending the REQUEST and OXID is receiving it, it is saving other DB fields
>> like name, shortdesc, imagenames etc but not saving any price field.
>> Obviously I have looked into my Logs first before I contacted here for
>> help. There is nothing in my logs, nothing in Exception file too. Request
>> is going in, the request is being processed and thats why I am becoming the
>> response in full and marked as successful (read it in the erp.log file) but
>> the price is not being transferred.
>>
>>
>>
>> It is a possibility that ERP is not sending the correct REQUEST and that
>> the OXID ERP module is working fine but for that I need to check the
>> REQUEST which is not being logged right now. :)
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> *Mit freundlichen Grüßen | Warm Regards,*
>>
>>
>> Mirza Ahtasham Ahmad
>> M +4917645387460 | Skype: ahtasham82
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> On Fri, Jul 15, 2016 at 10:47 AM, Keywan Ghadami <
>> keywan.ghad...@oxid-esales.com> wrote:
>>
>> Hi Mirza,
>>
>> I am sorry to hear that you did not got the support you wished,
>>
>> I will ask my colleges what went wrong in that case. who is your personal
>> contact person (SAM) or who is the person you did contact?
>>
>>
>>
>> In case of trouble or if you have a good reason, you can always get the
>> source code of OXID and all modules provided by OXID eSales, so it should
>> be easy to debug or add custom logging.
>>
>>
>>
>> The erp logs the request and response like this:
>>
>> date("Y-m-d H:i:s") . "\nREQUEST:\n" . $sRequest ."\nRESPONSE:\n" .
>> $sResponse . "\n\n";
>> in you erp logfile, if you do not have the request in the logfile it
>> means you request was causing some crash- have a *look in apache
>> error.log and EXCEPTION_LOG.txt*
>>
>>
>>
>> I usually use xdebug/soapui with the source version (I highly recommend
>> to contact support and ask for the source until you have it ;-))
>>
>>
>>
>> I really must point out that my colleges from the support team are really
>> good at their job, so I guess you should give it a second try an call them
>> again.
>>
>> You can also get you own contact person (SAM), reaction times within a
>> few hours, and of cause source code, and trainings – if it really comes to
>> problems they can’t solve by their own (e.g. not existing feature you need)
>> they can also contact Professional-Team or core team, or other partners to
>> provide support.
>>
>>
>>
>> There are also forum, skype channels … where you can try to get an answer.
>>
>>
>>
>> Best regards
>>
>>
>>
>> Keywan
>>
>>
>>
>>
>>
>> *Keywan Ghadami*
>> Senior Software-Entwickler Professional Services
>>
>> *keywan.ghad...@oxid-esales.com <keywan.ghad...@oxid-esales.com>*
>> Fon +49 761 36889-235
>> Fax +49 761 36889-29
>> *www.oxid-esales.com
>> <http://www.oxid-esales.com/?campaign=emailsignatur/oxid-esales-com&adword=OXSIG_Startseite>*
>>
>>
>> [image: OXID Commons] <http://www.oxid-commons.de/>
>>
>> *Rückblick OXID Commons 2016*
>> 02.06.2016, Freiburg
>>
>>
>>
>>
>>
>> *www.oxid-commons.de <http://www.oxid-commons.de/> Direkt zur
>> Bildergalerie
>> <https://www.flickr.com/photos/oxid-esales/sets/72157668976133352> OXID
>> eSales AG *Bertoldstraße 48
>> 79098 Freiburg
>> Deutschland
>>
>> Vorstand: Roland Fesenmayr (Vorsitzender), Dr. Marcus Klosterberg
>> Vorsitzender des Aufsichtsrats: Michael Schlenk, Sitz: Freiburg
>> Amtsgericht Freiburg i. Br., HRB 701648, USt-IdNr.: DE231450866
>>
>>
>>
>> *Von:* dev-general-boun...@lists.oxidforge.org [mailto:
>> dev-general-boun...@lists.oxidforge.org] *Im Auftrag von *Mirza Ahtasham
>> Ahmad
>> *Gesendet:* Freitag, 15. Juli 2016 10:15
>>
>>
>> *An:* dev-general@lists.oxidforge.org
>> *Betreff:* Re: [oxid-dev-general] ERP Module Issues
>>
>>
>>
>> OXID support...hahaha...its been 2 months now...It is like joke :) I
>> think the lawyers will take care of that,
>>
>>
>>
>> I thought that I would ask here in community and perhaps get a quicker
>> solution. A quicker response I did get obviously, thumbs up for that to the
>> community :)
>>
>>
>>
>> I myself can't dig into the module to solve the problem myself because
>> the module is encrypted. I think no one else uses the module thats why the
>> problem is not known. Literally the module has only one job to do that is
>> to save the values in DB and it is not doing that and OXID wont take the
>> responsibility to look into it. Great...
>>
>>
>>
>> Anyways, if someone has a hint, I will love to solve the issue as soon as
>> possible.
>>
>>
>>
>> Thanks,
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> *Mit freundlichen Grüßen | Warm Regards,*
>>
>>
>> Mirza Ahtasham Ahmad
>> M +4917645387460 | Skype: ahtasham82
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> On Fri, Jul 15, 2016 at 9:16 AM, Marat Bedoev <marat.bed...@bestlife.ag>
>> wrote:
>>
>> Did you try asking OXID support? Cause this mailing list is not a support
>> channel
>>
>>
>>
>> *Von:* dev-general-boun...@lists.oxidforge.org [mailto:
>> dev-general-boun...@lists.oxidforge.org] *Im Auftrag von *Mirza Ahtasham
>> Ahmad
>> *Gesendet:* Donnerstag, 14. Juli 2016 20:30
>>
>>
>> *An:* dev-general@lists.oxidforge.org
>> *Betreff:* Re: [oxid-dev-general] ERP Module Issues
>>
>>
>>
>> Hi,
>>
>>
>>
>> Can nobody help me regarding ERP Logging?? Anyone from OXID Guys ??
>> Atleast anyone from OXID should help regarding their ERP Connector. It says
>> in docs...
>>
>>
>>
>> ERP version 2.10.0 and higher has SOAP communication debugging
>> possibility implemented. It enables logging of full SOAP requests and
>> responses by adding the following configuration constant to shop’s
>> config.inc.php file:
>>
>>
>>
>> but it is only logging the RESPONSE and not REQUEST.
>>
>>
>>
>> Without the REQUEST Log I cannot debug my issue that I am having.
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> *Mit freundlichen Grüßen | Warm Regards,*
>>
>>
>> Mirza Ahtasham Ahmad
>> M +4917645387460 | Skype: ahtasham82
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> On Tue, Jul 12, 2016 at 9:33 AM, Reinhard Vogl <
>> reinhard.v...@deutschedaten.de> wrote:
>>
>> Hi,
>>
>>
>>
>> Idea for 1.)
>>
>> Can you look for your Mall settings?
>>
>> If you enabled the option “Indiv. Preis für vererbte Artikel erlauben”,
>> the prices are stored in the table oxfield2shop.
>>
>> Be sure, that you need individual process for inheritance, because it
>> slows down ERP import a lot.
>>
>>
>>
>> 2.) rsync is your friend
>>
>>
>>
>> Greets,
>>
>> Reini
>>
>>
>>
>> *Von:* dev-general-boun...@lists.oxidforge.org [mailto:
>> dev-general-boun...@lists.oxidforge.org] *Im Auftrag von *Mirza Ahtasham
>> Ahmad
>> *Gesendet:* Dienstag, 12. Juli 2016 09:26
>> *An:* dev-general@lists.oxidforge.org
>> *Betreff:* Re: [oxid-dev-general] ERP Module Issues
>>
>>
>>
>> ​1. It is saving the values in OXID. what I am trying to say is that the
>> transfer from ERP to OXID does happen as I posted the SOAP Response, I get
>> the Posted Article ID and blResult is true and I see the article in OXID
>> Backend. But I only the Price is not being saved. Because all the Price
>> fields in OXID are empty. I assume the ERP is not sending the correct
>> request, meaning it is not sending the price in the correct parameter.
>>
>>
>>
>> For that I wanted to check the log​s but there is another problem with
>> logs. The logs of the ERP Module, only prints the RESPONSE in erp.log file
>> and not the REQEUST so I cannot varify my hypothesis that the ERP is
>> sending wrong REQUEST.
>>
>>
>>
>> Therefore at first, I need to fix the Logging Problem of ERP Connector.
>> Has anyone a suggestion there ?????
>>
>>
>>
>>
>>
>>
>>
>> 2. With image transfer, thats what I thought, that the ERP Connector only
>> saves the DB Fields values such as pic name in oxpic fields but not
>> actually transfers the image file. For that I will have to write a routine
>> that uploads the images to the correct directories. I just wanted to be
>> sure, not that I have missed something in configuration of ERP Module.
>> Thanks.
>>
>>
>>
>>
>>
>> I will be grateful if someone can help me out with the Logging problem.
>>
>>
>>
>> Thanks,
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> *Mit freundlichen Grüßen | Warm Regards,*
>>
>>
>> Mirza Ahtasham Ahmad
>> M +4917645387460 | Skype: ahtasham82
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> On Mon, Jul 11, 2016 at 7:36 PM, Michael Bladowski <
>> mbladow...@macropage.de> wrote:
>>
>> dear mirza,
>>
>> Am 11.07.2016 um 18:29 schrieb Mirza Ahtasham Ahmad:
>>
>> Hi Guys,
>>
>>
>>
>> I have a Shop version EE 5.2.7. I have also installed the ERP
>> Connector MOD_ERP_2.14.1_OXID_ESHOP_EE_5.2.1_4.9.1_for_PHP5.6
>>
>>
>>
>> I have 2 issues that I am facing.
>>
>>
>>
>> 1. The Product Price is not being transfered to oxid shop. I am getting
>> back a response with Product OXID and blResult as true in return.
>>
>>
>>
>>
>>
>>
>> if the values are changed in DB but not at the frontend, clear (the
>> front-end) cache, if you are using one.
>> if the values are not changed in DB, i guess the request itself has an
>> error, wrong format, wrong oxid, unwanted
>> chars inside request, there are many things, did you test it with any
>> other field than price ? before you use php
>> (or any other coding lang) i recommend to setup a working call with
>> soapui <https://www.soapui.org/downloads/soapui.html>, to be 100% sure
>> your problems are
>> not realted to the shop.
>>
>>
>>
>> 2. Issue is more a How To Question....How can I transfer the images of
>> products and categories. via ERP SetArticle method image names can be sent
>> to shop but the image file, how can it be transfered on the server. The ERP
>> that is being used is "Comarch-ERP" there you can give the FTP Username
>> and password where the files can be uploaded but in OXID all the master
>> paths for product and categories are different so thats why I am unable to
>> transfer the product images.
>>
>>
>> i don´t know all the specs about the latest oxid, but for me the best
>> solution has always been, NOT using the ERP api.
>> as i know the ERP api, its only for changing DB data, nothing that is
>> related to the filesystem (okay, if you delete an item, the images get
>> deleted, but
>> i don´t speak about internal things like that) ;) i don´t know whats best
>> practise but i always try to keep the images on the server before i make any
>> ERP api calls, make sure the images are already there inside the correct
>> directories, copy via ftp, scp, ssh, what ever makes sense in your case.
>> btw... it should be possible to extend the ERP api with a self written
>> module to send the raw image within the SetArticle call, but for me that
>> makes no sense because the webserver would need to handle more data as is
>> should. i would recommend to make a seperate process, that copies
>> your images to the server whenever changes happen to them.
>>
>> bets wishes,
>> micha
>>
>> --
>>
>> *MACROPAGE e.K.*
>>
>> Michael Bladowski
>>
>>
>>
>> Hauptstrasse 84D - 93105 Tegernheim - Mobil: 0179-2301067
>>
>> mbladow...@macropage.de - http://i.am.a.php-api.expert
>>
>> Regensburg HRA 7490 - Finanzamt Regensburg DE 210758353
>>
>>
>>
>>
>> _______________________________________________
>> dev-general mailing list
>> dev-general@lists.oxidforge.org
>> http://dir.gmane.org/gmane.comp.php.oxid.general
>>
>>
>>
>>
>> _______________________________________________
>> dev-general mailing list
>> dev-general@lists.oxidforge.org
>> http://dir.gmane.org/gmane.comp.php.oxid.general
>>
>>
>>
>>
>> _______________________________________________
>> dev-general mailing list
>> dev-general@lists.oxidforge.org
>> http://dir.gmane.org/gmane.comp.php.oxid.general
>>
>>
>>
>>
>> _______________________________________________
>> dev-general mailing list
>> dev-general@lists.oxidforge.org
>> http://dir.gmane.org/gmane.comp.php.oxid.general
>>
>>
>>
>> _______________________________________________
>> dev-general mailing list
>> dev-general@lists.oxidforge.org
>> http://dir.gmane.org/gmane.comp.php.oxid.general
>>
>
>
_______________________________________________
dev-general mailing list
dev-general@lists.oxidforge.org
http://dir.gmane.org/gmane.comp.php.oxid.general

Reply via email to