On Wed, 9 Mar 2005, Matt Benson <[EMAIL PROTECTED]> wrote:

> Right now I am leaning toward:
> 
> public interface oata.types.FileCollection {
>     public Iterator iterator();//of Files
> }

Iterator works for me, but so would an array.  We do have some cases
where we only want to check whether a collection is empty, the
resulting on-liner may be easier to read with an array.

Resource instead of File could be even better.

> I still need a name for "an absolute collection of
> files" that is hopefully short enough to make a usable
> XML element name a la FileSet, and am eagerly awaiting
> suggestions.

I like DD's suggestion of <files> as well.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to