Hello Matthias,

2017-03-20 7:43 GMT+01:00 Matthias Apitz <g...@unixarea.de>:

>
> Hello,
>
> I have the following host and build:
>
>   SUSE Linux Enterprise Server 12 (x86_64) SP0
>
>   apache: 2.4.23 with a patch for OpenSSL 1.1
>   apr-1.5.2
>   apr-util-1.5.4
>   OpenSSL 1.1.0d
>
> all the above compiled for 32-bit (because we are a software distributor
> and
> have to support 32-bit hardware too).
>
> This crashes on start of httpd with the gdb backtrace attached below. It
> seems that the problem is coming down from a call within libapr-1.so or
> mod_ssl.so
>
> The exact same suite works fine on Solaris SunOS 10.
>
> What are the options? Do we have to recompile apache(...) with OpenSSL
> 1.0.x?


[sneaking in the dev@apr list, non authoritative answer but it might help]

Openssl 1.1.x support is now merged in the latest 2.4.x httpd branch and it
will be included in the next release, but for 2.4.23 you'd need to use
1.0.x. You can check
http://people.apache.org/~jorton/httpd-2.4.x-openssl110.patch if you want
more details about what changed.

Thanks!

Luca

Reply via email to