-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/60578/#review179407
-----------------------------------------------------------




addons/models/0010-base_model.json
Lines 99 (patched)
<https://reviews.apache.org/r/60578/#comment254093>

    Consider naming this as: dataset_process_inputs
    Also, swap the endDefs: endDef1 -> dataset; endDef2 -> process. I think 
this would be intutive to read.



addons/models/0030-hive_model.json
Lines 527 (patched)
<https://reviews.apache.org/r/60578/#comment254094>

    Consider the following:
    - rename as 'hive_db_table' - from container to contained
    - swap the endDefs: endDef1=hive_db; endDef2=hive_table
    - propagateTags: TWO_TO_ONE ==> ONE_TO_TWO



addons/models/0030-hive_model.json
Lines 619 (patched)
<https://reviews.apache.org/r/60578/#comment254098>

    I would suggest to keep the container end as endDef1.



addons/models/0050-falcon_model.json
Lines 162 (patched)
<https://reviews.apache.org/r/60578/#comment254099>

    I would suggest to keep the container end as endDef1. Also, rename the 
relationship as "falcon_cluster_feed"



addons/models/0050-falcon_model.json
Lines 181 (patched)
<https://reviews.apache.org/r/60578/#comment254100>

    I would suggest to keep the container end as endDef1. Also, rename the 
relationship as "falcon_cluster_process"



addons/models/0050-falcon_model.json
Lines 200 (patched)
<https://reviews.apache.org/r/60578/#comment254101>

    I would suggest to keep the container end as endDef1. Also, rename the 
relationship as "falcon_cluster_feed_creation"



intg/src/main/java/org/apache/atlas/type/AtlasEntityType.java
Lines 118 (patched)
<https://reviews.apache.org/r/60578/#comment254103>

    add "@Override"



intg/src/main/java/org/apache/atlas/type/AtlasEntityType.java
Lines 147 (patched)
<https://reviews.apache.org/r/60578/#comment254105>

    Consider making the following as unmodifiable:
     - allSubTypes                = Collections.unmodifiableSet(allSubTypes);
     - typeAndAllSubTypes         = 
Collections.unmodifiableSet(typeAndAllSubTypes);
     - relationshipAttributes     = 
Collections.unmodifiableMap(relationshipAttributes);
     - relationshipAttributesType = 
Collections.unmodifiableMap(relationshipAttributesType);
    
    Also, update accessors of these fields to simply return the member, instead 
of wrapping it with Collections.unmodifiable..()



intg/src/main/java/org/apache/atlas/type/AtlasTypeRegistry.java
Lines 368 (patched)
<https://reviews.apache.org/r/60578/#comment254106>

    Please move these comments from here to appropriate file.


- Madhan Neethiraj


On June 30, 2017, 8:25 p.m., Sarath Subramanian wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/60578/
> -----------------------------------------------------------
> 
> (Updated June 30, 2017, 8:25 p.m.)
> 
> 
> Review request for atlas, David Radley and Madhan Neethiraj.
> 
> 
> Bugs: ATLAS-1907
>     https://issues.apache.org/jira/browse/ATLAS-1907
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> Create relationshipDefs for all out of the box models. Use relationshipDef 
> information when creating edges for composite attributes in entities.
> 
> 
> Diffs
> -----
> 
>   addons/models/0010-base_model.json 7f64d85e 
>   addons/models/0030-hive_model.json b359ea82 
>   addons/models/0050-falcon_model.json b7398ef4 
>   addons/models/0060-hbase_model.json 42fe00c4 
>   addons/models/0080-storm_model.json 095936e0 
>   intg/src/main/java/org/apache/atlas/AtlasErrorCode.java 49ead6e3 
>   intg/src/main/java/org/apache/atlas/model/instance/AtlasRelationship.java 
> 8d2e7ec5 
>   intg/src/main/java/org/apache/atlas/type/AtlasEntityType.java 70e3067a 
>   intg/src/main/java/org/apache/atlas/type/AtlasRelationshipType.java 
> f85cf35c 
>   intg/src/main/java/org/apache/atlas/type/AtlasStructType.java c2e0be50 
>   intg/src/main/java/org/apache/atlas/type/AtlasTypeRegistry.java 29fae1c8 
>   
> repository/src/main/java/org/apache/atlas/repository/store/bootstrap/AtlasTypeDefStoreInitializer.java
>  4530f51b 
>   
> repository/src/main/java/org/apache/atlas/repository/store/graph/v1/AtlasEntityStoreV1.java
>  5ea4ff20 
>   
> repository/src/main/java/org/apache/atlas/repository/store/graph/v1/AtlasGraphUtilsV1.java
>  7b3f1e6e 
>   
> repository/src/main/java/org/apache/atlas/repository/store/graph/v1/AtlasRelationshipStoreV1.java
>  86212338 
>   
> repository/src/main/java/org/apache/atlas/repository/store/graph/v1/EntityGraphMapper.java
>  ebf6a201 
>   
> repository/src/test/java/org/apache/atlas/repository/store/graph/v1/AtlasRelationshipStoreV1Test.java
>  PRE-CREATION 
> 
> 
> Diff: https://reviews.apache.org/r/60578/diff/1/
> 
> 
> Testing
> -------
> 
> Tested using Postman REST client.
> Validated all hive_table creation works fine and lineage is rendered right.
> 
> UTs/ITs in progress.
> 
> 
> Thanks,
> 
> Sarath Subramanian
> 
>

Reply via email to