-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/72865/#review221900
-----------------------------------------------------------


Ship it!




Validated the docker build process using docker-compose. 

Atlas builds fine and starts in container. Ran quickstart and verified entities 
are created fine.

- Sarath Subramanian


On Sept. 11, 2020, 10:55 p.m., Madhan Neethiraj wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/72865/
> -----------------------------------------------------------
> 
> (Updated Sept. 11, 2020, 10:55 p.m.)
> 
> 
> Review request for atlas, Ashutosh Mestry, Jayendra Parab, keval bhatt, Mehul 
> Parikh, Nikhil Bonte, Nixon Rodrigues, Sarath Subramanian, Sharmadha Sainath, 
> and Sidharth Mishra.
> 
> 
> Bugs: ATLAS-3934
>     https://issues.apache.org/jira/browse/ATLAS-3934
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> - added docker files, docker-compose files and scripts to build Atlas in a 
> container. The image to build Atlas supports following volumns:
> -- scripts: build scripts in the local directory will be made available in 
> the container
> -- dist:    archives from the build will be copied into this volume
> -- .m2:     if provided, build uses the give .m2 directory, which can help 
> avoid large downloads
> -- patches: patche files, if present, will be applied on top of the specified 
> github branch
> -- src:     if provided, builds from the sources in this directory (instead 
> of from sources from github)
> 
> - added docker file, docker-compose file and scripts to install and run Atlas 
> in a container.
> 
> - note: this patch depends on updates in ATLAS-3939, which is under review
> 
> 
> Diffs
> -----
> 
>   dev-support/atlas-docker/.dockerignore PRE-CREATION 
>   dev-support/atlas-docker/Dockerfile.atlas PRE-CREATION 
>   dev-support/atlas-docker/Dockerfile.atlas-base PRE-CREATION 
>   dev-support/atlas-docker/Dockerfile.atlas-build PRE-CREATION 
>   dev-support/atlas-docker/README.md 5296f05ba 
>   dev-support/atlas-docker/dist/.gitignore PRE-CREATION 
>   dev-support/atlas-docker/docker-compose.atlas-base.yml PRE-CREATION 
>   dev-support/atlas-docker/docker-compose.atlas-build.yml PRE-CREATION 
>   dev-support/atlas-docker/docker-compose.atlas.yml PRE-CREATION 
>   dev-support/atlas-docker/patches/.gitignore PRE-CREATION 
>   dev-support/atlas-docker/scripts/atlas-build.sh PRE-CREATION 
>   dev-support/atlas-docker/scripts/atlas.sh PRE-CREATION 
> 
> 
> Diff: https://reviews.apache.org/r/72865/diff/1/
> 
> 
> Testing
> -------
> 
> - verified build with the following command:
>    docker-compose -f docker-compose.atlas-base.yml -f 
> docker-compose.atlas-build.yml up
> 
> - verified install and running of Atlas with the following command:
>    docker-compose -f docker-compose.atlas-base.yml -f 
> docker-compose.atlas.yml up -d
> 
> - Ran quick start successfully
> 
> 
> Thanks,
> 
> Madhan Neethiraj
> 
>

Reply via email to