> On Jan. 20, 2017, 5:10 p.m., Suma Shivaprasad wrote:
> > intg/src/main/java/org/apache/atlas/type/AtlasClassificationType.java, line 
> > 97
> > <https://reviews.apache.org/r/55753/diff/1/?file=1610433#file1610433line97>
> >
> >     rename to resolveSubTypes?
> 
> Madhan Neethiraj wrote:
>     resolveReferences2() - the second-stage resolve method might be useful 
> for other purposes as well. Hence I think it will be good to keep the name 
> generic.

Maybe we could rename this to resolveReferencesPhase2?


> On Jan. 20, 2017, 5:10 p.m., Suma Shivaprasad wrote:
> > intg/src/main/java/org/apache/atlas/type/AtlasEntityType.java, line 290
> > <https://reviews.apache.org/r/55753/diff/1/?file=1610434#file1610434line290>
> >
> >     we should also add a subType check? for eg : array<employee> can hold a 
> > manager or an employee. So subType check would work there
> 
> Madhan Neethiraj wrote:
>     array<employee> having an element of type manager would be allowed - as 
> this check 'is employee superTypeOf manager' would return true.
>     
>     However, this would prevent array<manager> from having an element of type 
> employee. This is the correct behaviour, right?

Yes that should work correctly. Was evaluting the other way around when I was 
thinking about it :)


- Suma


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55753/#review162441
-----------------------------------------------------------


On Jan. 20, 2017, 10:30 a.m., Madhan Neethiraj wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55753/
> -----------------------------------------------------------
> 
> (Updated Jan. 20, 2017, 10:30 a.m.)
> 
> 
> Review request for atlas.
> 
> 
> Bugs: ATLAS-1490
>     https://issues.apache.org/jira/browse/ATLAS-1490
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> added resolveReferences2() to compile list of sub-types for each 
> entity/classification type
> 
> 
> Diffs
> -----
> 
>   intg/src/main/java/org/apache/atlas/type/AtlasClassificationType.java 
> 7d89848 
>   intg/src/main/java/org/apache/atlas/type/AtlasEntityType.java caadecc 
>   intg/src/main/java/org/apache/atlas/type/AtlasType.java b7502d3 
>   intg/src/main/java/org/apache/atlas/type/AtlasTypeRegistry.java c88e559 
>   intg/src/test/java/org/apache/atlas/model/ModelTestUtil.java ac740c9 
>   
> intg/src/test/java/org/apache/atlas/model/instance/TestAtlasClassification.java
>  6dc72ee 
>   intg/src/test/java/org/apache/atlas/model/instance/TestAtlasEntity.java 
> efcf1cf 
>   intg/src/test/java/org/apache/atlas/type/TestAtlasTypeRegistry.java d171dcf 
> 
> Diff: https://reviews.apache.org/r/55753/diff/
> 
> 
> Testing
> -------
> 
> - added tests to verify new functionality
> - existing unit tests pass successfully
> 
> 
> Thanks,
> 
> Madhan Neethiraj
> 
>

Reply via email to