[ 
https://issues.apache.org/jira/browse/BAHIR-91?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15889619#comment-15889619
 ] 

ASF GitHub Bot commented on BAHIR-91:
-------------------------------------

GitHub user tzulitai opened a pull request:

    https://github.com/apache/bahir-flink/pull/11

    [BAHIR-91] Upgrade Flink version to 1.2.0

    This required some Flink state API updates in the tests. We probably should 
keep an extra eye for these kind of Flink API changes; the source APIs may be 
stable, but API changes like these can also break code in bahir-flink.
    
    Note about the additional `maven-bundle-plugin` in the Redis connector:
    After the 1.2.0 upgrade, the project had a new dependency to Apacheds JDBM 
2.0.0-M2, which packages using the "bundle" type. The plugin helps recognizes 
the type when building.


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/tzulitai/bahir-flink BAHIR-91

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/bahir-flink/pull/11.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #11
    
----
commit 9b9be286543fb8c972d48e715a724da261f71d24
Author: Tzu-Li (Gordon) Tai <tzuli...@apache.org>
Date:   2017-03-01T06:41:21Z

    [BAHIR-91] Upgrade Flink version to 1.2.0

----


> Upgrade bahir-flink to support Flink 1.2
> ----------------------------------------
>
>                 Key: BAHIR-91
>                 URL: https://issues.apache.org/jira/browse/BAHIR-91
>             Project: Bahir
>          Issue Type: New Feature
>          Components: Flink Streaming Connectors
>    Affects Versions: Flink-0.1
>         Environment: Ubuntu Yakkety Yak
>            Reporter: Markus Müller
>             Fix For: Flink-0.1
>
>
> After working around  https://issues.apache.org/jira/browse/FLINK-4813 by 
> specifying Flink version 1.3-SNAPSHOT instead of 1.2.0 in the bahir-flink pom 
> file, I get the following compiler errors for the ActiveMQ connector:
> ERROR] 
> /home/markus/src/bahir-flink/flink-connector-activemq/src/test/java/org/apache/flink/streaming/connectors/activemq/ActiveMQConnectorITCase.java:[32,33]
>  error: cannot find symbol
> [ERROR]   symbol:   class ForkableFlinkMiniCluster
>   location: package org.apache.flink.test.util
> /home/markus/src/bahir-flink/flink-connector-activemq/src/test/java/org/apache/flink/streaming/connectors/activemq/ActiveMQConnectorITCase.java:[54,19]
>  error: cannot find symbol
> [ERROR]   symbol:   class ForkableFlinkMiniCluster
>   location: class ActiveMQConnectorITCase
> /home/markus/src/bahir-flink/flink-connector-activemq/src/test/java/org/apache/flink/streaming/connectors/activemq/ActiveMQConnectorITCase.java:[66,20]
>  error: cannot find symbol
> [ERROR]   symbol:   class ForkableFlinkMiniCluster
>   location: class ActiveMQConnectorITCase
> /home/markus/src/bahir-flink/flink-connector-activemq/src/test/java/org/apache/flink/streaming/connectors/activemq/ActiveMQConnectorITCase.java:[216,22]
>  error: method snapshotState in class 
> MessageAcknowledgingSourceBase<Type,UId> cannot be applied to given types;
> [ERROR]   required: FunctionSnapshotContext
>   found: long,long
>   reason: actual and formal argument lists differ in length
>   where Type,UId are type-variables:
>     Type extends Object declared in class MessageAcknowledgingSourceBase
>     UId extends Object declared in class MessageAcknowledgingSourceBase
> /home/markus/src/bahir-flink/flink-connector-activemq/src/test/java/org/apache/flink/streaming/connectors/activemq/ActiveMQConnectorITCase.java:[229,4]
>  error: ActiveMQConnectorITCase.TestSourceContext is not abstract and does 
> not override abstract method markAsTemporarilyIdle() in SourceContext
> Excluding ActiveMQ from compilation leads to the next issue in the 
> Akka-Connector:
> [ERROR] 
> /home/markus/src/bahir-flink/flink-connector-akka/src/test/java/org/apache/flink/streaming/connectors/akka/AkkaSourceTest.java:[210,17]
>  error: DummySourceContext is not abstract and does not override abstract 
> method markAsTemporarilyIdle() in SourceContext
> [INFO] 1 error



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to