ASF GitHub Bot commented on BAHIR-110:

Github user emlaver commented on a diff in the pull request:

    --- Diff: 
sql-cloudant/src/main/scala/org/apache/bahir/cloudant/CloudantReceiver.scala ---
    @@ -16,23 +16,20 @@
     package org.apache.bahir.cloudant
    -// scalastyle:off
    -import scalaj.http._
     import play.api.libs.json.Json
    +import scalaj.http._
    +import org.apache.spark.SparkConf
     import org.apache.spark.storage.StorageLevel
     import org.apache.spark.streaming.receiver.Receiver
    -import org.apache.spark.SparkConf
     import org.apache.bahir.cloudant.common._
    -// scalastyle:on
     class CloudantReceiver(sparkConf: SparkConf, cloudantParams: Map[String, 
         extends Receiver[String](StorageLevel.MEMORY_AND_DISK) {
    -  lazy val config: CloudantConfig = {
    +  lazy val config: CloudantChangesConfig = {
    --- End diff --
    From our conversation over Slack, let's not change the name of the 
`CloudantReceiver` class.

> Replace use of _all_docs API with _changes API in all receivers
> ---------------------------------------------------------------
>                 Key: BAHIR-110
>                 URL: https://issues.apache.org/jira/browse/BAHIR-110
>             Project: Bahir
>          Issue Type: Improvement
>            Reporter: Esteban Laver
>   Original Estimate: 216h
>  Remaining Estimate: 216h
> Today we use the _changes API for Spark streaming receiver and _all_docs API 
> for non-streaming receiver. _all_docs API supports parallel reads (using 
> offset and range) but performance of _changes API is still better in most 
> cases (even with single threaded support).
> With this ticket we want to:
> a) re-implement all receivers using _changes API
> b) compare performance between the two implementations based on _changes and 
> _all_docs
> Based on the results in b) we could decide to either
> - replace _all_docs implementation with _changes based implementation OR
> - allow customers to pick one (with a solid documentation about pros and 
> cons) 

This message was sent by Atlassian JIRA

Reply via email to