[ 
https://issues.apache.org/jira/browse/BAHIR-123?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Esteban Laver updated BAHIR-123:
--------------------------------
    Description: 
The latest version is 2.6.2.  Error during mvn install -pl sql-cloudant after 
updating play-json to 2.6.2 in sql-cloudant/pom.xml:

[ERROR] 
/Users/estebanmlaver/emlaver-bahir/sql-cloudant/src/main/scala/org/apache/bahir/cloudant/common/JsonStoreConfigManager.scala:19:
 object typesafe is not a member of package com
[ERROR] import com.typesafe.config.ConfigFactory
[ERROR]            ^
[ERROR] 
/Users/estebanmlaver/emlaver-bahir/sql-cloudant/src/main/scala/org/apache/bahir/cloudant/common/JsonStoreConfigManager.scala:52:
 not found: value ConfigFactory
[ERROR]   private val configFactory = ConfigFactory.load()
[ERROR]                               ^
[ERROR] two errors found

Maven compile dependencies need to be added to pom.xml that existed in 
play-json 2.5.9 but were removed in 2.6.2.

Additional info. from Patrick Titzler between play-json versions 2.5.x and 
2.6.x:
Looks like the parameter data type has been changed from `Seq[JsValue]` 
(https://www.playframework.com/documentation/2.5.x/api/scala/index.html#play.api.libs.json.JsArray)
 to `IndexedSeq[JsValue]` 
https://playframework.com/documentation/2.6.x/api/scala/index.html#play.api.libs.json.JsArray

  was:
The latest version is 2.6.2.  Error during mvn install -pl sql-cloudant:

[ERROR] 
/Users/estebanmlaver/emlaver-bahir/sql-cloudant/src/main/scala/org/apache/bahir/cloudant/common/JsonStoreConfigManager.scala:19:
 object typesafe is not a member of package com
[ERROR] import com.typesafe.config.ConfigFactory
[ERROR]            ^
[ERROR] 
/Users/estebanmlaver/emlaver-bahir/sql-cloudant/src/main/scala/org/apache/bahir/cloudant/common/JsonStoreConfigManager.scala:52:
 not found: value ConfigFactory
[ERROR]   private val configFactory = ConfigFactory.load()
[ERROR]                               ^
[ERROR] two errors found


Additional info. from Patrick Titzler between play-json versions 2.5.x and 
2.6.x:
Looks like the parameter data type has been changed from `Seq[JsValue]` 
(https://www.playframework.com/documentation/2.5.x/api/scala/index.html#play.api.libs.json.JsArray)
 to `IndexedSeq[JsValue]` 
https://playframework.com/documentation/2.6.x/api/scala/index.html#play.api.libs.json.JsArray


> Fix errors to support the latest version of Play JSON library for sql-cloudant
> ------------------------------------------------------------------------------
>
>                 Key: BAHIR-123
>                 URL: https://issues.apache.org/jira/browse/BAHIR-123
>             Project: Bahir
>          Issue Type: Task
>            Reporter: Esteban Laver
>            Priority: Minor
>
> The latest version is 2.6.2.  Error during mvn install -pl sql-cloudant after 
> updating play-json to 2.6.2 in sql-cloudant/pom.xml:
> [ERROR] 
> /Users/estebanmlaver/emlaver-bahir/sql-cloudant/src/main/scala/org/apache/bahir/cloudant/common/JsonStoreConfigManager.scala:19:
>  object typesafe is not a member of package com
> [ERROR] import com.typesafe.config.ConfigFactory
> [ERROR]            ^
> [ERROR] 
> /Users/estebanmlaver/emlaver-bahir/sql-cloudant/src/main/scala/org/apache/bahir/cloudant/common/JsonStoreConfigManager.scala:52:
>  not found: value ConfigFactory
> [ERROR]   private val configFactory = ConfigFactory.load()
> [ERROR]                               ^
> [ERROR] two errors found
> Maven compile dependencies need to be added to pom.xml that existed in 
> play-json 2.5.9 but were removed in 2.6.2.
> Additional info. from Patrick Titzler between play-json versions 2.5.x and 
> 2.6.x:
> Looks like the parameter data type has been changed from `Seq[JsValue]` 
> (https://www.playframework.com/documentation/2.5.x/api/scala/index.html#play.api.libs.json.JsArray)
>  to `IndexedSeq[JsValue]` 
> https://playframework.com/documentation/2.6.x/api/scala/index.html#play.api.libs.json.JsArray



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to