AfterWatermarkEarlyAndLate has:
   public AfterWatermarkEarlyAndLate withEarlyFirings(OnceTrigger earlyTrigger)
   public AfterWatermarkEarlyAndLate withLateFirings(OnceTrigger lateTrigger)
FromEndOfWindow has:
   public AfterWatermarkEarlyAndLate withEarlyFirings(OnceTrigger earlyFirings) 
  public AfterWatermarkEarlyAndLate withLateFirings(OnceTrigger lateFirings)
As a means of trying to understand the trigger API, I am curious if it might 
make sense conceptually to:
1. rename AfterWatermarkEarlyAndLate => EarlyAndLate since it is already an 
inner class of AfterWatermark2. get rid of FromEndOfWindow by having 
AfterWatermark.pastEndOfWindow() return a new 
AfterWatermarkEarlyAndLate(Never.ever(), null);
Or is there a value to having FromEndOfWindow be separate that I am not 

Wesley Tanaka

Reply via email to