Hi Svet,

Thanks for letting us know!

I know some of these have already been addressed, see https://github.com/
apache/brooklyn-client/pull/63 for one of the CLI ones for instance. I
think we really need to do a 0.12.1 release to fix some of them on the
current release.

Thanks

Duncan

On 20 November 2017 at 13:22, Geoff Macartney <[email protected]>
wrote:

> hi Svet,
>
> thanks for the heads-up; I'll raise BROOKLYN- issues for the CLI issues;
> don't know if we need a new one for the AWS deployment or if that's already
> covered by 412 as you mention?
>
> Geoff
>
>
>
> On Mon, 20 Nov 2017 at 11:27 Светослав Нейков <[email protected]>
> wrote:
>
> > Hi folks,
> >
> > Wanted to do a quick test with Brooklyn yesterday so went and downloaded
> > latest 0.12 release. Here are some of the things that didn't work out
> quite
> > as expected, mostly related to the command line client.
> >
> > * The web app still shows the user in quotes - I thought we got this
> fixed
> > but might've slipped through the cracks.
> > * Deploying a basic app to AWS London with a minimal location results in
> > the error:
> >
> > AWSResponseException: request POST https://ec2.eu-west-2.amazonaws.com/
> > HTTP/1.1 <https://ec2.eu-west-2.amazonaws.com/HTTP/1.1> failed with code
> > 400, error:
> > AWSError{requestId='fb5dc6dc-562e-4572-b854-80f61718a9b5',
> > requestToken='null', code='Unsupported', message='The requested
> > configuration is currently not supported. Please check the documentation
> > for supported configurations.', context='{Response=, Errors=}'}
> >
> > Adding a hardwareId fixes it. Probably a case of BROOKLYN-412.
> >
> >
> > * "br --help" crashes (or any other option)
> > * br will not tell you if you got the argument ordering wrong - needed
> some
> > time to remember how it worked. For example:
> >   "br entity xxx" always results in 404 - note the URL it's trying to
> fetch
> > is "GET /v1/applications//entities/cl8z1sxvl7" (missing the app part)
> >   "br delete app xxx entity yyy" always results in 405 and tries to hit
> > "DELETE /v1/applications/"
> > * "br app xxx delete" doesn't quite work - removes the app without
> tearing
> > it down. Seems it's doing unmanage and not expunge as the help suggests.
> > Also throws the following exception:
> >
> >
> > ./br app sgfcmfwfyb delete
> > {1511176504033 0 false In progress { {   }} destroying
> > BasicApplicationImpl{id=sgfcmfwfyb} map[] REST call to destroy
> application
> > Paystubs (BasicApplicationImpl{id=sgfcmfwfyb})   false { {   }} <nil>
> false
> > Task[destroying BasicApplicationImpl{id=sgfcmfwfyb}]@EGXv12Vu
> >
> > In progress (RUNNABLE)
> > At:
> >
> > org.apache.brooklyn.core.mgmt.internal.NonDeploymentManagementContext
> .getSubscriptionManager(NonDeploymentManagementContext.java:249)
> >
> >
> > org.apache.brooklyn.core.mgmt.internal.EntityManagementSupport.
> onManagementStopping(EntityManagementSupport.java:311)
> >
> >
> > org.apache.brooklyn.core.mgmt.internal.LocalEntityManager$3.
> apply(LocalEntityManager.java:511)
> >
> >
> > org.apache.brooklyn.core.mgmt.internal.LocalEntityManager$3.
> apply(LocalEntityManager.java:508)
> >
> >
> > org.apache.brooklyn.core.mgmt.internal.LocalEntityManager.recursively(
> LocalEntityManager.java:645)
> >
> >
> > org.apache.brooklyn.core.mgmt.internal.LocalEntityManager.
> unmanage(LocalEntityManager.java:508)
> >
> >
> > org.apache.brooklyn.core.mgmt.internal.LocalEntityManager.
> unmanage(LocalEntityManager.java:461)
> >
> >
> > org.apache.brooklyn.core.mgmt.internal.LocalEntityManager.
> unmanage(LocalEntityManager.java:456)
> >
> >
> > org.apache.brooklyn.rest.util.BrooklynRestResourceUtils$2.
> run(BrooklynRestResourceUtils.java:421)
> >
> >
> > org.apache.brooklyn.util.core.task.BasicExecutionManager$
> SubmissionCallable.call(BasicExecutionManager.java:529)
> > []  false map[self:/v1/activities/EGXv12Vu
> > children:/v1/activities/EGXv12Vu/children] EGXv12Vu 1511176504033}
> >
> >
> > Best,
> > Svet.
> >
>

Reply via email to