On Wed, Jul 8, 2009 at 5:50 PM, Daniel Spiewak <djspie...@gmail.com> wrote:
> > If it broke, I'll probably spend an hour of frustration before I catch > why > > my tests are not working as expected. On the other hand, buildr package > > test=no vs buildr package build_test=no ... no contest. And I like being > > able to export test=no. > > > I agree 100% that it should remain `buildr package test=no`. It would > drive > me batty if we changed that. However, I question whether export test=no is > really all that useful. Or, more importantly, I question whether `export > BUILDR_TEST=no` is really all that inconvenient. To me at least, this > looks > a lot more representative of what it's doing (setting the TEST property for > the BUILDR tool). I don't think there would be any confusion if we had > BUILDR_TEST for the envar and test for the invocation form, particularly > since one is capitalized while the other is not (as per the Unix > convention). This would be my preference as well... with the caveat that variable bindings passed on the command-line would be specific to Buildr and no longer general environment variable equivalents. I understand it would break from Rake conventions as well. alex