Hi In these examples from: http://camel.apache.org/advicewith
I think the adviceById and adviceByToString should be renamed to selectById and selectByToString As they are used for selecting node(s) in the route path. Maybe matchById to indicate its a pattern and that it can match multiple nodes? On Sun, Feb 20, 2011 at 12:12 PM, Claus Ibsen <[email protected]> wrote: > Hi > > As part of the roadmap for Camel 2.7 > http://camel.apache.org/camel-27-roadmap.html > > We had improved testing on the agenda. > > So I have improved this offering the following new features > - added assertPeriod to mock, to enforce assertion is still valid > after a grace period (for example that messages dont continue to > arrive) > - automatic mocking endpoints (you dont have to add mocks to your > routes, as Camel offers convention over configuration) > - possible to test with arrival times and set expectation, such as > that subsequent messages should be no later than 2 seconds apart > - advice with can now manipulate routes such as replacing, removing, > adding node(s) to the advice routed > > For more details see > https://cwiki.apache.org/confluence/display/CAMEL/Mock > https://cwiki.apache.org/confluence/display/CAMEL/AdviceWith > > In terms of advice with we have introduced a new > AdviceWithRouteBuilder which offers specialized DSL for unit testing. > Take a look at the wiki pages as they have examples. > > Feedback welcome, especially about the DSL and if the chosen fluent > builder is named reasonable. > > > > -- > Claus Ibsen > ----------------- > FuseSource > Email: [email protected] > Web: http://fusesource.com > Twitter: davsclaus > Blog: http://davsclaus.blogspot.com/ > Author of Camel in Action: http://www.manning.com/ibsen/ > -- Claus Ibsen ----------------- FuseSource Email: [email protected] Web: http://fusesource.com Twitter: davsclaus Blog: http://davsclaus.blogspot.com/ Author of Camel in Action: http://www.manning.com/ibsen/
