> On Mar 13, 2017, at 1:46 PM, Aristedes Maniatis <a...@maniatis.org> wrote: > > > Just a wild thought, but would this syntax be helpful... > > List<Object[]> result = ObjectSelect.query(Artist.class) > .addColumns(Artist.PAINTING_COUNT) > .select(context); > > So then we are adding more columns to the existing DataObject query rather > than having to define the DataObjects as properties in themselves. The syntax > above might be simpler to understand and write.
So "addColumns" vs "columns"? IIRC we tried something similar with orderings (override all orderings vs add to the existing orderings), and that confused everybody (including me as the author), so that was undone between the milestones. Andrus