Hi Michael

Sorry I wasn't clear. What I meant is with an EXTRA boolean parameter like in my original API proposal, like so:

public ObjectSelect apply( boolean onCondition, Consumer<ObjectSelect> op )
{
    if ( onCondition ) op.accept( this );
    return this;
}


On Tue, 09 Jul 2024 17:11:33 +0200, Michael Gentry <blackn...@gmail.com> wrote:

Hi Jurgen!

In general, I'd like to avoid using boolean parameters unless you are
actually setting a boolean, like setEnabled(). I'm not sure how you
intended to use the boolean, but I think an enum or better-named method is better.

mrg

Reply via email to