On 15 September 2016 at 12:06, Stian Soiland-Reyes <st...@apache.org> wrote:
> [[ Cross-posting - let's try to reply to dev@commons. ]]

> b) Move RDFParserBuilder to package org.apache.commonsrdf.experimental
>  or similar (allowing us to fully change it for the next version)

> c) Same as b) - but also move RDFParserBuilder implementations to e.g.
> org.apache.commonsrdf.jena.experimental

> e) Remove RDFParserBuilder.rdfTermFactory()

These are my proposed changes - I'll go ahead on these unless I hear
otherwise :)


Commons folks - is the use of a ".experimental" sub-package (and
appropriate Javadoc) OK?

Suggested javadoc:

package org.commons.rdf.api.experimental;
/**
  * ...
  * <p>
  * NOTE: This interface/class is currently marked as
<strong>experimental</strong>,
  * meaning that it might change or be removed in the next minor version.
  */
public interface RDFParserBuilder {
  // ...
}


I'm not proposing we go all Guava style with lots of experimental
annotations (and the well known incompatibility issues following),
just for this 0.3.0-incubating version - so we can decide later on the
final form of that interface for the following (hopefully 1.0.0)
version under Commons proper.


-- 
Stian Soiland-Reyes
http://orcid.org/0000-0001-9842-9718

Reply via email to