[ 
https://issues.apache.org/jira/browse/DAFFODIL-1903?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16364390#comment-16364390
 ] 

Michael Beckerle commented on DAFFODIL-1903:
--------------------------------------------

sbt-eclipse plugin doesn't capture the dependency on daffodil-macro-lib, so 
that has to be added to the eclipse build paths manually, at which point one 
might as well just maintain them manually. 

> Eclipse classpath broken for daffodil-test and other tests - now must have 
> daffodil-lib-unittest
> ------------------------------------------------------------------------------------------------
>
>                 Key: DAFFODIL-1903
>                 URL: https://issues.apache.org/jira/browse/DAFFODIL-1903
>             Project: Daffodil
>          Issue Type: Bug
>          Components: Infrastructure
>    Affects Versions: 2.1.0
>            Reporter: Michael Beckerle
>            Assignee: Michael Beckerle
>            Priority: Major
>             Fix For: 2.1.0
>
>
> Moving built-in-formats from daffodil-lib to daffodil-lib-unittest breaks 
> many things. Every eclipse project that depended on that file is broken and 
> must have its eclipse classpath modified.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to