Matthew Hayes commented on DATAFU-90:

Hey [~rleidle], sorry I didn't notice this issue before.  I was just going 
through open issues and found it.  Is the ugly sed still necessary?  DataFu 
isn't using Ivy anymore (we now use Gradle for building).  The DataFu pom 
doesn't list Pig as a dependency (I think before this wasn't the case).  So I 
think this is probably not an issue anymore, but let us know.

> Unable to override the pig version parameter or refer to a locally built 
> version of Pig in the datafu ivy.xml or ivysettings.xml
> --------------------------------------------------------------------------------------------------------------------------------
>                 Key: DATAFU-90
>                 URL: https://issues.apache.org/jira/browse/DATAFU-90
>             Project: DataFu
>          Issue Type: Improvement
>            Reporter: Rob Leidle
>            Priority: Minor
> In the Bigtop project we are forced to do several ugly sed replacements on 
> the ivy.xml and ivysettings.xml to work around issues with Datafu.
> https://issues.apache.org/jira/browse/BIGTOP-1840
> https://github.com/apache/bigtop/blob/master/bigtop-packages/src/common/datafu/do-component-build
> Can you guys help us make it easier to integrate datafu into Bigtop?

This message was sent by Atlassian JIRA

Reply via email to