Hi,

currently our hidden input is called "dsPostWindowId".
This breaks the compatibility with PF partialSubmit feature ->
https://issues.apache.org/jira/browse/DELTASPIKE-446

In PrimeFaces partialSubmit mode, we just collect all inputs which will be
processed.
If the form will NOT be processed, we manually collect
javax.faces.ViewState and javax.faces.ClientWindow and add them as post
params.

If we would rename it to javax.faces.ClientWindow, DS would be compatible
with partialSubmit and we would avoid duplicate hidden inputs if DS runs on
JSF 2.2.

Regards,
Thomas

Reply via email to