imo the definition should be simple: if it depends on deltaspike-core, it's
a module

@romain:

again:
> there is no issue with api-/name-/... changes >before< v1. we had a
similar change in codi (before v1) and there was no issue with it.
> (+ we emphasized the possibility of such changes from the very beginning).

regards,
gerhard



2014-02-14 10:08 GMT+01:00 Romain Manni-Bucau <rmannibu...@gmail.com>:

> well I don't agree on modules hierarchy which looks inconsistent but I
> dont really care while code is here but I agree with Mark names are
> already used 'in fact it is true for this and for core) so we
> shouldn't change it anymore.
> Romain Manni-Bucau
> Twitter: @rmannibucau
> Blog: http://rmannibucau.wordpress.com/
> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> Github: https://github.com/rmannibucau
>
>
>
> 2014-02-14 9:38 GMT+01:00 Karl Kildén <karl.kil...@gmail.com>:
> > As far as I understand , it would be more symmetric from the outside /
> > overview but technically asymmetric because the dependencies are
> different.
> >
> > But the name change feels harmless and would bring balance to the force.
> >
> >
> > On 14 February 2014 09:31, Thomas Andraschko <
> andraschko.tho...@gmail.com>wrote:
> >
> >> IMHO there is no difference between our modules and cdictrl.
> >>
> >> However, we should rename it to something like "container-control" to
> match
> >> our other project names.
> >>
> >>
> >>
> >> 2014-02-14 8:55 GMT+01:00 Mark Struberg <strub...@yahoo.de>:
> >>
> >> > I'm still -1 (veto) because I'm not convinced that it has ANY benefit.
> >> >
> >> >
> >> > The issue is that CdiCtrl as a whole has NOTHING to do with our real
> >> > 'modules'. They do not share even a single import, do not even have a
> >> > dependency to ds-core.
> >> >
> >> >
> >> > How would you explain a fresh user who is looking at our code that all
> >> the
> >> > parent pom dependencies do not get used only in this very project?
> How do
> >> > you prevent other people from adding dependencies randomly?
> >> >
> >> > It also has a different build lifecycle basically. Actually it's
> really
> >> > more a project part on it's own than just a module for ds-core.
> >> >
> >> > I'm a bit undecided about the test-control. It needs CdiCtrl _and_
> >> > ds-core. But it's also essentially not a ds module neither.
> >> >
> >> > LieGrue,
> >> > strub
> >> >
> >> >
> >> >
> >> >
> >> > On Monday, 10 February 2014, 13:23, Gerhard Petracek <
> >> > gerhard.petra...@gmail.com> wrote:
> >> >
> >> > +1 there is no issue with api-/name-/... changes >before< v1. we had a
> >> > >similar change in codi (before v1) and there was no issue with it.
> >> > >(+ we emphasized the possibility of such changes from the very
> >> beginning).
> >> > >
> >> > >if we change something like that, we should also re-visit the
> >> > >security-module (the initial reason for creating an own module isn't
> >> there
> >> > >any longer).
> >> > >
> >> > >regards,
> >> > >gerhard
> >> > >
> >> > >
> >> > >
> >> > >
> >> > >2014-02-10 13:17 GMT+01:00 Thomas Andraschko <
> >> andraschko.tho...@gmail.com
> >> > >:
> >> > >
> >> > >> Can't we change the parent?
> >> > >> IMHO renaming isn't a problem if we do it BEFORE 1.0.
> >> > >>
> >> > >>
> >> > >> 2014-02-10 13:07 GMT+01:00 Mark Struberg <strub...@yahoo.de>:
> >> > >>
> >> > >> > We could rename the module, but I'd rather not move it under
> modules
> >> > >> > because they don't have the same parent. And we also must not
> change
> >> > the
> >> > >> > artifactId as cdictrl is already heavily used in projects.
> >> > >> >
> >> > >> >
> >> > >> > LieGrue,
> >> > >> > strub
> >> > >> >
> >> > >> >
> >> > >> >
> >> > >> >
> >> > >> > On Monday, 10 February 2014, 13:05, Thomas Andraschko <
> >> > >> > andraschko.tho...@gmail.com> wrote:
> >> > >> >
> >> > >> > +1 for renaming to container-controler and both under modules
> >> > >> > >
> >> > >> > >
> >> > >> > >
> >> > >> > >2014-02-10 12:28 GMT+01:00 John D. Ament <
> john.d.am...@gmail.com>:
> >> > >> > >
> >> > >> > >> -1 for cdi unit (name already in use for the exact same
> purpose)
> >> > >> > >>
> >> > >> > >> +1 for renaming cdictrl to container-control
> >> > >> > >>
> >> > >> > >> +1 for aligning both under modules (even though cdictrl has no
> >> > deps on
> >> > >> > >> core, making it a module makes it easier to understand from a
> >> > user's
> >> > >> > >> point of view).
> >> > >> > >>
> >> > >> > >> Personally, since it's an upgrade of the version # people just
> >> > need to
> >> > >> > >> be aware of it when doing the upgrade locally in their
> projects
> >> > (e.g.
> >> > >> > >> we can put some notes out there on what needs to be done to
> >> > upgrade).
> >> > >> > >>
> >> > >> > >> On Mon, Feb 10, 2014 at 5:47 AM, Romain Manni-Bucau
> >> > >> > >> <rmannibu...@gmail.com> wrote:
> >> > >> > >> > test-control could be renamed cdi-unit or something like it
> >> IMHO
> >> > >> > >> > Romain Manni-Bucau
> >> > >> > >> > Twitter: @rmannibucau
> >> > >> > >> > Blog: http://rmannibucau.wordpress.com/
> >> > >> > >> > LinkedIn: http://fr.linkedin.com/in/rmannibucau
> >> > >> > >> > Github: https://github.com/rmannibucau
> >> > >> > >> >
> >> > >> > >> >
> >> > >> > >> >
> >> > >> > >> > 2014-02-10 11:28 GMT+01:00 Gerhard Petracek <
> >> > >> > gerhard.petra...@gmail.com
> >> > >> > >> >:
> >> > >> > >> >> i wouldn't move test-control, since it's a module based on
> >> > >> > >> deltaspike-core.
> >> > >> > >> >> (cdictrl isn't based on deltaspike-core.)
> >> > >> > >> >>
> >> > >> > >> >> regards,
> >> > >> > >> >> gerhard
> >> > >> > >> >>
> >> > >> > >> >>
> >> > >> > >> >>
> >> > >> > >> >> 2014-02-10 11:15 GMT+01:00 Mark Struberg <
> strub...@yahoo.de>:
> >> > >> > >> >>
> >> > >> > >> >>> Well, cdictrl is released already. Thus I would rather not
> >> > change
> >> > >> > it's
> >> > >> > >> >>> name.
> >> > >> > >> >>> test-control is not yet released. So that would be easier
> to
> >> > >> change.
> >> > >> > >> >>>
> >> > >> > >> >>> LieGrue,
> >> > >> > >> >>> strub
> >> > >> > >> >>>
> >> > >> > >> >>>
> >> > >> > >> >>>
> >> > >> > >> >>>
> >> > >> > >> >>>
> >> > >> > >> >>> On Sunday, 9 February 2014, 20:16, Karl Kildén <
> >> > >> > karl.kil...@gmail.com>
> >> > >> > >> >>> wrote:
> >> > >> > >> >>>
> >> > >> > >> >>> Hello,
> >> > >> > >> >>> >
> >> > >> > >> >>> >I know it's been discussed before but now with a module
> >> called
> >> > >> > >> >>> test-control
> >> > >> > >> >>> >it just feel unnecessary to be inconsistent even though
> >> > cdiCtrl
> >> > >> is
> >> > >> > >> not a
> >> > >> > >> >>> >module it's not so pretty...
> >> > >> > >> >>> >
> >> > >> > >> >>> >Cheers / Karl
> >> > >> > >> >>> >
> >> > >> > >> >>> >
> >> > >> > >> >>> >
> >> > >> > >> >>>
> >> > >> > >>
> >> > >> > >
> >> > >> > >
> >> > >> >
> >> > >>
> >> > >
> >> > >
> >> >
> >>
>

Reply via email to