[
https://issues.apache.org/jira/browse/FELIX-3069?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13080559#comment-13080559
]
Guillaume Sauthier commented on FELIX-3069:
-------------------------------------------
Sure, it isn't more efficient.
It's just that you have injected what you need, no more, no less.
Concerning bugs, indeed: more code means more potential bugs, anyway, that
feature do not looks very complex to implement: once you get the service,
you're basically done.
It was just something I feel as "nice to have", maybe inspired from CDI
programming model...
> Support adapted bind/unbind method signature
> --------------------------------------------
>
> Key: FELIX-3069
> URL: https://issues.apache.org/jira/browse/FELIX-3069
> Project: Felix
> Issue Type: New Feature
> Components: iPOJO
> Reporter: Guillaume Sauthier
> Priority: Minor
>
> iPOJO already supports some basic bind/unbind methods signature (notification
> only, gives the service, with ServiceRef or not, with a Map or not).
> I would like to be able to have the service + any additional service property
> I'm interested in.
> Something like the following code:
> {noformat}
> public void bindAdapter(XmlAdapter adapter,
> @Extract("namespace-uri")) uri) {
> }
> {norformat}
> With @Extract (better name to be found) extracting the "namespace-uri"
> service property from the ServiceReference and giving it to this method.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira