[ 
https://issues.apache.org/jira/browse/FELIX-5665?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16122501#comment-16122501
 ] 

AnilKumar Attuluri commented on FELIX-5665:
-------------------------------------------

[~karlpauls]
Thanks a lot for the excellent feedback. May be I should have added a comment 
before I started working on it today.

I implemented your comments except for searching explicit imports and clearing 
the cache when a class is found via dynamic import.

Can you please look at my changes as well, while I test the patch: 
https://github.com/apache/felix/pull/116

I believe we still need this to be enabled with a property and not as the 
default behavior?



> High CPU usage on sun.reflect.Generated* class loads by log4j 
> --------------------------------------------------------------
>
>                 Key: FELIX-5665
>                 URL: https://issues.apache.org/jira/browse/FELIX-5665
>             Project: Felix
>          Issue Type: Improvement
>          Components: Framework
>    Affects Versions: framework-5.6.4
>            Reporter: AnilKumar Attuluri
>             Fix For: framework-5.6.8
>
>         Attachments: FELIX-5665.patch, IMG_1.jpg, IMG_2.jpg
>
>
> We have been running some performance tests to prepare our OSGi bundle 
> (*running in Apache Karaf*) for production.
> Just to give some background about our OSGi bundle, we converted an existing 
> Spring application into an OSGi bundle with all the current dependencies 
> packaged into the bundle as an uber artifact.
> When we run >= 500 TPS (each of these calls results in a http call made via a 
> library) we run into this high CPU usage spikes reaching up to 100% CPU. 
> Please see the image attached, the spikes in the image are 100% CPU usage 
> while the average is about 40%. Also see the CPU sampler image which points 
> to 
> *org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation*
> Is there an existing bug/documentation that already captures this?
> We don't see this behavior when we run the same app in standalone JVM.
>  



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to