[ 
https://issues.apache.org/jira/browse/FELIX-5885?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Carsten Ziegeler reassigned FELIX-5885:
---------------------------------------

    Assignee: Carsten Ziegeler

> Felix SCR uses an overly restrictive import range for promises
> --------------------------------------------------------------
>
>                 Key: FELIX-5885
>                 URL: https://issues.apache.org/jira/browse/FELIX-5885
>             Project: Felix
>          Issue Type: Bug
>          Components: Declarative Services (SCR)
>    Affects Versions: scr-2.1.0
>            Reporter: Timothy Ward
>            Assignee: Carsten Ziegeler
>            Priority: Major
>             Fix For: scr-2.1.2
>
>
> The Felix SCR bundle embeds the OSGi promise library at version 1.0 to make 
> it easy to deploy DS. This is great, but the import range used is [1.0,1.1), 
> which prevents users of the DS API from using promises 1.1.
> There should be no reason that Felix SCR needs to haveĀ a provider import 
> range - it should be able to substitute any backward compatible version and 
> use a range of [1,2).



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to