Hi Thynn,


Steps you have followed are perfect.

I can only suspect some step is not done properly.

As long as global script is modified and you are able to run report outside
of the mifos installation, your report should be good.


You should have something wrong in the report entries.

As mentioned in the sourceforge link, have you tried configuring the param

This is a data integrity issue caused by "parameterName":null,"value":

null,"args"  meaning although you have provided the parameter in sql query

but haven't configured in Mifos - Create report.


How to fix:

In System>>Manage reports>>Create report >> After inputting all the

required fields, you need to "*Select allowed paramters*"(Report parameters)

Click on *Add* button >> then *provide the **Parameter Name passed to

Pentaho* >> then click on *submit*.





From: Thynn Win [mailto:thynn....@thitsaworks.com] 
Sent: 22 September 2016 04:59
To: dev@fineract.incubator.apache.org
Subject: [Mifos-developer] Custom Pentaho Report -- unable to parse the


Hello all,


I am experiencing exactly the same error as mentioned in this thread and
would like to seek your help. If there was a solution, could you please
share with us?




We have a pentaho report (prpt) querying against Microsoft Azure SQL
Database and it runs well independently. We are trying to place this report
in Mifos as a Custom Report in a multi-tenant environment. 

By having this report in Mifos, our end users can perform all their
functions within Mifos (though this custom report does not rely on Mifos
data from mysql).



*         Mifos is installed on Ubuntu on Amazon EC2


What was done so far:

1.       Put three parameters (tenantURL, user and password) in Pentaho
report as mentioned in this tutorial
t+and+Embedding+it+to+MifosX> .

2.       Global script doesn't seem to be relevant as the report isn't
querying mysql. But I put it there and tweaked a bit but no luck.

3.       Placed this prpt (Pentaho Report) in ./root/.mifosx/pentahoReports
(along with other out-of-the-box prpts) and set the same permission settings
as other prpts.

4.       Update the security in Azure to allow connection from this server.

5.       Placed Microsoft odbc jar in tomcat folders


6.       Restarted tomcat7

7.       Created new parameters in stretchy_parameters table
(mifostenant-default schema). 

8.       In Mifos, created a new report with the newly created parameters.
Verified that they are properly associated in stretchy_report_parameters.


The result:

The report shows up in the report drop down but nothing rendered. When
reviewing the debug log, it's calling fineract api and receiving 403 (unable
to parse the document). 

What I have tried:

1.       I used a separate sql tool to connect to Azure to ensure Mifos
server can connect to SQL server. It worked. Not firewall or connection

2.       I am suspecting the global script - I tried with it, without it,
with just the declaration part but same error.

3.       In Azure MSSQL server, I am logging every query and the search
doesn't seem to reach there. 

4.       Checked the logs (fineract, catalina, etc,), only INFO about the
service calls but no ERROR or WARN.


Any help would be highly appreciated.







Reply via email to