[ 
https://issues.apache.org/jira/browse/FLAGON-304?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Joshua Poore updated FLAGON-304:
--------------------------------
    Priority: Minor  (was: Critical)

> Update entire TAP Build
> -----------------------
>
>                 Key: FLAGON-304
>                 URL: https://issues.apache.org/jira/browse/FLAGON-304
>             Project: Flagon
>          Issue Type: Improvement
>          Components: TAP
>    Affects Versions: Tap 0.1.0
>            Reporter: Lewis John McGibbney
>            Assignee: Arthi Vezhavendan
>            Priority: Minor
>             Fix For: Tap 0.2.0
>
>
> When one builds the Docker composition for TAP, there are several dire 
> WARNINGS which we should definitely address
> {code}
> Step 8/19 : RUN npm install -g bower gulp
>  ---> Running in 1c372060e1ec
> npm WARN deprecated bower@1.8.4: We don't recommend using Bower for new 
> projects. Please consider Yarn and Webpack or Parcel. You can read how to 
> migrate legacy project here: 
> https://bower.io/blog/2017/how-to-migrate-away-from-bower/
> npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, 
> following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
> npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for 
> compatibility with current and future versions of Node.js
> npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or 
> higher to avoid a RegExp DoS issue
> npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or 
> higher to avoid a RegExp DoS issue
> npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for 
> compatibility with current and future versions of Node.js
> {code}
> Specifically migrating away from Bower. 
> https://bower.io/blog/2017/how-to-migrate-away-from-bower/



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to